Anfänger frage

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
TextBox
Bild

Betrifft: Anfänger frage
von: Sascha
Geschrieben am: 02.12.2003 17:16:54

Hallo liebe Freunde!
Habe zwei fragen
- A1 wird durch Textbox1 verändert


Private Sub TextBox1_Change()
   ActiveCell.Offset(0, 0) = TextBox1.Value
End Sub

Dadurch wird B1 durch Formel mit sverweis ebenfalls verändert
Wie kann ich erreichen das bei eingabe in Textbox1 gleichzeitig in Textbox2 aktuelle wert von B1 erscheint. Habe mit

Private Sub TextBox6_Change()
    TextBox6.Value = ActiveCell.Offset(0, 1).Value
End Sub

Versucht aber es funktioniert nicht

- In D1- soll wert nach Formel
=SVERWEIS(C1;F50000:D50500;2;0)
- In D2- soll wert nach Formel
=SVERWEIS(C2;F50000:D50500;2;0) und so weiter bis 45000
Ist es möglich mit code das zu machen
Danke in voraus
Gruß Sascha
Bild


Betrifft: AW: Anfänger frage
von: Nike
Geschrieben am: 02.12.2003 17:29:14

Hi,

>Wie kann ich erreichen das bei eingabe in Textbox1
>gleichzeitig in Textbox2 aktuelle wert von B1 erscheint.

So:


Private Sub TextBox1_Change()
   ActiveCell.Offset(0, 0) = TextBox1.Value
   TextBox2.Value = range("B1").value
End Sub


Bye

Nike


Bild


Betrifft: AW: Anfänger frage
von: Sascha
Geschrieben am: 02.12.2003 18:15:47

DANKE NIKE
Hast du was für zweites problem -
In D1- soll wert nach Formel
=SVERWEIS(C1;F50000:D50500;2;0)
- In D2- soll wert nach Formel
=SVERWEIS(C2;F50000:D50500;2;0) und so weiter bis 45000
Ist es möglich mit code das zu machen


Bild

Beiträge aus den Excel-Beispielen zum Thema " Close-Event der Druckvorschau"