Microsoft Excel

Herbers Excel/VBA-Archiv

verweis-funktion

Betrifft: verweis-funktion von: Steffi
Geschrieben am: 23.08.2004 17:25:37

Hallo zusammen,

ich habe eine "Art" Formular erstellt, indem verschiedene Daten vom Anwender reinkopiert werden und über bestimmte Inhalte (ID's) eine Abfrage in einer zweiten Tabelle vorgenommen wird. Der Inhalt dieser Abfrage soll über eine wenn-Formel je nach "wahr" oder "falsch" entsprechend zurückgemeldet werden.

Meine Formel sieht derzeit, wie folgt aus:

=WENN($A11="";"";WENN(ISTFEHLER(VERWEIS(A:A;'Tabelle Aug. 04'!B:B;'Tabelle Aug. 04'!B:B))=WAHR;"keine ID";"ID"))

Die Spalte A enthält ID's, die vom Anwender reinkopiert werden (die Inhalte sind also mit jedem neuen Einfügen verändert).
Die Spalte B der Tabelle Aug. 04 enthält eine konstante Liste von ID's.

Derzeit gibt die Formel falsche Werte zurück so, dass "ID" angegeben wird, obwohl diese in der Tabelle Aug. 04 nicht vorhanden ist.

Könnt ihr mir sagen, was hier schief läuft und wie ich die Formel anpassen kann??

Wäre super...

Vielen Dank vorab und viele Grüße

  


Betrifft: VERWEIS ist hier wohl fehl am Platze... von: Boris
Geschrieben am: 23.08.2004 17:44:26

Hi Steffi,

...da die Funktion nicht auf EXAKTE Übereinstimmung prüfen kann.
Entweder ausweichen auf SVERWEIS - mit dem 4. Paramter FALSCH (bzw. 0 ), oder aber einfach zählen mit ZÄHLENWENN.

Grüße Boris


  


Betrifft: AW: verweis-funktion von: Andre
Geschrieben am: 23.08.2004 17:48:58

Hi,

versuch´s mal so:

=WENN($A11="";"";WENN(ISTFEHLER(VERWEIS(A11;'Tabelle Aug. 04'!B:B;'Tabelle Aug. 04'!B:B))=WAHR;"keine ID";"ID"))

mfg Andre


 

Beiträge aus den Excel-Beispielen zum Thema "verweis-funktion"