Microsoft Excel

Herbers Excel/VBA-Archiv

Verknüpfung Wenn/Oder

Betrifft: Verknüpfung Wenn/Oder von: Carsten
Geschrieben am: 24.08.2004 11:29:22

Hallo liebe Excel Freunde,

ich habe folgendes Problem:

Eine Zelle kann 8 verschiedene Zahlen haben 51, 53, 55, 57, 58, 100, 101, 102.

Wenn einer dieser Zahlen erscheint soll in der Nachbarzelle die jeweilige Zahl mit den Buchsteben ACS davor erscheinen. (ACS51, ACS53, ACS55, ACS57, ACS58, ACS100, ACS101, ACS102).

Leider bekomme ich dies mit einer verschachtelten WENN-ODER Formel nicht hin. Hat jemand eine andere Idee?

Danke! Gruß aus dem Norden

  


Betrifft: AW: Verknüpfung Wenn/Oder von: michel
Geschrieben am: 24.08.2004 11:37:48

Hallo Carsten

=WENN(ODER(A1=51;A1=53;A1=55;A1=57;A1=58;A1=100;A1=101;A1=102);"ACS"&A1;"")

damit gelingt es dir..du musst nur noch das a1 durch die entsprechende Zelle ersetzen.

Grüße michel


  


Betrifft: Und noch eine kleine Verkürzung von: Boris
Geschrieben am: 24.08.2004 11:44:13

Hi Michel,

du kannst dir Tipparbeit sparen, wenn du die fraglichen Werte in eine Matrix packst:
=WENN(ODER(A1={51.53.55.57.58.100.102});"ACS"&A1;"")

Grüße Boris


  


Betrifft: AW: Und noch eine kleine Verkürzung von: Carsten
Geschrieben am: 24.08.2004 11:51:02

Danke für die schnelle Hilfe, das sieht ja einfach aus. Prima!!!


  


Betrifft: AW: Verknüpfung Wenn/Oder von: Andre
Geschrieben am: 24.08.2004 11:42:04

Hi Carsten,

so geht´s zwar nicht elegant, aber funktioniert!

=WENN(A1=51;"ACS51";WENN(A1=53;"ACS53";WENN(A1=55;"ACS55";WENN(A1=57;"ACS57";WENN(A1=58;"ACS58";WENN(A1=100;"ACS100";WENN(A1=101;"ACS101";WENN(A1=102;"ACS102";""))))))))

Gruß Andre