Microsoft Excel

Herbers Excel/VBA-Archiv

Prozentformel

Betrifft: Prozentformel von: Bolli
Geschrieben am: 26.08.2004 19:06:02

Hallo!

Mein Problem ist folgendermassen:

D3*1/B3 dies ist die Formel für meine Aufgabe, Wenn aber in B3 nichts steht soll im Feld F3 wo die Prozente angezeigt werden keine #### stehen sondern
0% oder garnichts.

Hoffe einer von euch kann mir helfen.

Macht weiterso ihr seid Klasse.

BOLLI

  


Betrifft: AW: Prozentformel von: OttoH
Geschrieben am: 26.08.2004 19:30:04

=wenn(B3=0;"";d3/b3)

Gruß OttoH


  


Betrifft: AW: Prozentformel von: guenther
Geschrieben am: 26.08.2004 19:44:34

Etwas besser wäre vieleicht:
=WENN(ISTLEER(B3);0;D3/B3)
Unter Extras - Optionen dann die Nullwerte deaktivieren, dann steht nichts in der Zelle, man kann diese aber für weitere Berechnungen verwenden, ohne dass eine Fehlermeldung kommt.

Gruß Guenther


  


Betrifft: AW: Prozentformel von: Bolli
Geschrieben am: 26.08.2004 19:50:10

Super OttoH!

=wenn(B3=0;?;d3/b3)

Was bedeuten die Strichelchen was muss darein. leider hast du es mit einem ganz Blinden zu tuen. Tut mir leid ..

Bolli
danke inm vorraus.


  


Betrifft: AW: Prozentformel von: OttoH
Geschrieben am: 26.08.2004 21:43:34

Zwischen die Gänsefüsschen kommt nix, nicht mal ein Leerzeichen; dann steht auch nix in der Zelle.


Gruß OttoH


  


Betrifft: AW: Prozentformel von: Georg
Geschrieben am: 26.08.2004 21:27:21

Hallo Bolli,

"" heißt, es gibt keinen Wert in dieser Zelle, also auch keine Null.

Für Dein Problem entweder: Wenn(B3="";"";D3*1/B3) oder wenn Du mit Nullwerten arbeitest:
Wenn(B3=0;"";D3*1/B3). In beiden Fällen erhälst Du keine Fehlermeldung.
Grüße
Georg


  


Betrifft: AW: Prozentformel von: guenther
Geschrieben am: 27.08.2004 08:31:52

Wenn du sowohl für eine leere Zelle als auch für eine Zelle mit dem Wert 0 keine Fehlermeldung habén willst, solltest du die folgende Formel benutzen:
WENN(ODER(ISTLEER(B3);B3=0);0;D3/B3)
d.h. es wird erst geprüft ob die Zelle B3 leer ist oder ob diese Zelle den Wert 0 hat,trifft eine der beiden Bedingungen zu erhält die Zelle den Rückgabewert 0, ist der Wert der Zelle >0 wird die Berechnung D3/B3 ausgeführt.

Guenther