Microsoft Excel

Herbers Excel/VBA-Archiv

SummeWenn

Betrifft: SummeWenn von: bocomtex
Geschrieben am: 27.08.2004 11:04:42

Ich habe folgendes Problem
In Spalt A stehen Farbnamen in Spalte B Gewichte,
nun möchte ich in Spalte C nur die Farbnamen addieren an deren Endung ein r
steht. Wie kann ich das machen?
Denn mit Summewenn kann ich wohl Zahlen wie 10 usw unterscheiden, aber nicht
mit einem Bindesterich usw.

Spalte A Spalte B

1-15 150
1-15r 180
2-03 200
2-18r 75

Danke für eine Antwort

Günter

  


Betrifft: AW: SummeWenn von: Mac4
Geschrieben am: 27.08.2004 11:09:49

Hallo Günter,

so müsste es gehen:

=SUMMEWENN(A:A;"*r*";B:B)

Marc (aus Köln)


  


Betrifft: AW: SummeWenn von: bocomtex
Geschrieben am: 27.08.2004 11:23:51

Hallo und Danke

Damit =SUMMEWENN(A:A;"*r*";B:B)
hat geklappt.

Gruss
Günter


  


Betrifft: AW: SummeWenn von: Jan
Geschrieben am: 27.08.2004 11:15:38

Hi Günter,


Vielleicht so: =SUMMEWENN(A7:A10;"*r";B7:B10)


Jan


  


Betrifft: AW: SummeWenn von: Ingo
Geschrieben am: 27.08.2004 11:18:45

Du kannst eine Hilfsspalte einrichten.
z,B in Spalte D = rechts(Spalte A;1)
und dann die Summewenn über Spalte D
mfG
Ingo Christiansen


 

Beiträge aus den Excel-Beispielen zum Thema "SummeWenn"