Microsoft Excel

Herbers Excel/VBA-Archiv

Suchen

Betrifft: Suchen von: Lars
Geschrieben am: 06.09.2004 13:53:30

Ich habe ein Problem, und zwar habe ich eine Tabelle mit einigen tausend Datensätzen.
Die Datensätze beinhalten Arbeitsgänge, z.B. Rohr anschweißen,
Blech schweißen, Schraube abschweißen.
Ich würde nun gerne alle Arbeitsgänge raussuchen, die "schweiß" beinhalten,
egal an welcher Position. Anschließend sollte mir aber auch die Anzahl der gefundenen Datensätze ausgegeben werden, die die jeweilig von mir vorgegeben Zeichenfolge beinhaltet.

Kann mir da jemand weiterhelfen???

Vielen Dank!!!

  


Betrifft: AW: Suchen von: Bert
Geschrieben am: 06.09.2004 13:58:09

Funktion z.B. in B1: =ZÄHLENWENN(A:A;"*schweiß*")

Bert


  


Betrifft: AW: Suchen von: Gert Seler
Geschrieben am: 06.09.2004 15:30:01

Hallo Bert,
teile die vorhandenen Datensätze in "Arbeits_Gruppen" (z.B. "*schweiß*"; "*nieten*" usw)
mit der Formel:=ZÄHLENWENN(A10;"*schweiß*") in Spalte B abwärts kopieren.
In der B spalte werden alle gefundenen "Textwerte" mit 1 dargestellt.
Die Summe kann zum Abschluß gebildet werden.
So kannst Du alle Datensätze in Gruppen einteilen, was zur besseren Übersicht beiträgt.
mfg
Gert



  


Betrifft: AW: Suchen von: Harald E
Geschrieben am: 06.09.2004 13:59:25

Hallo Lars,

versuchs mal so

Daten Filter Autofilter benutzerdefiniert
entspricht *schweiß*

Gruß
Harald


  


Betrifft: AW: Suchen von: Lars
Geschrieben am: 06.09.2004 14:10:18

Vielen Dank!!!


 

Beiträge aus den Excel-Beispielen zum Thema "Suchen"