Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrfachabfrage

Betrifft: Mehrfachabfrage von: Boris
Geschrieben am: 10.09.2004 11:46:02

Hi Excel Community,

ich brauche - mal wieder *gg* - eure Hilfe. Ich Möchte eine eine Mehrfachabfrage tätigen.

Also sie muß 2 Prüfungen enthalten und ist eine Addition von Werten einer Tabelle!

Sie soll aus 2 Abfragen bestehen. Ist der Wert V1? Und die 2te Abfrage lautet, ob die Woche mit dem Suchdatum übereinstimmt. (s. Tabelle)

Wenn diese beiden Werte zutreffen sollte dann ein Makro, dass den Funktionsnamen "Abfrage_Begriffe" hat die Werte auszählen, auf die diese Kriterien zutreffen.

Helft mit Bitte

MfG
Boris


  


Betrifft: AW: Mehrfachabfrage von: Björn B.
Geschrieben am: 10.09.2004 22:03:44

Hallo Boris,

muss es denn ein Makro sein oder reicht dir auch eine Formel?

Wenn ja, dann schreib in D18 mal folgendes rein:


=SUMMENPRODUKT((B2:B55=E18)*(C2:C55>F18-WOCHENTAG(F18))*(C2:C55<F18+8-WOCHENTAG(F18)))


Statt 55 musst du das Ende deiner Liste (oder der Tabelle (65536)) eintragen (insgesamt dreimal).

Gruß
Björn