Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis + Zeile runter

Betrifft: Sverweis + Zeile runter von: Hatschipu
Geschrieben am: 10.09.2004 12:47:19

Hallo,

kann mnir einer die Sverweis-Formel nennen,
in der man nicht bloß den spaltenindex, sondern auch noch nen zeilenindex angeben kann.

Bsp.: habe in einem tabellenblatt einer artikelliste mit spalte 1(artikelnr.) und spalte 2(bezeichnung). die bezeichnung zu einer bestimmten arikelnr steht jedoch über mehrere spalten beschrieben.
Will, dass im anderen tabellenblatt, bei eingabe der artikelnr, nicht nur die dazugehörige spalte rechts daneben, sondern auch die Bezeichung 1 (2,3,usw.) Spalte darunter erscheint.

Denke es ist mit ner speziellen form des sverweises zu lösen. nur wie?

kann mir jemand helfen? danke.

  


Betrifft: mit indirekt(Adresse(...)) oder Index-Vergleich von: Günther Oppold
Geschrieben am: 10.09.2004 12:57:44

Hallo Hatschi

mein Vorschlag:
Tabelle1
 ABCDE
1ArtikelMenge Preis  
2123150  
31235047  
412315045  
5124160  
612410058  
7125180  
8     
9   mit Indirektmit Index
10 Menge1Preis1Menge2Preis2
1112416010058
Formeln der Tabelle
B11 : =SVERWEIS($A11;$A$2:$C$7;2;0)
C11 : =SVERWEIS($A11;$A$2:$C$7;3;0)
D11 : =INDIREKT(ADRESSE(VERGLEICH(A11;A2:A7;0)+2;2;;;))
E11 : =INDEX(C2:C7;VERGLEICH(A11;A2:A7;0)+1)
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther PS: Gesundheit ;-)

 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis + Zeile runter"