Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis Variabler Bereich

Betrifft: SVerweis Variabler Bereich von: Josef
Geschrieben am: 15.09.2004 08:23:20

Hallo,

der SVerweis sieht wie folgt aus:

anzZeilen = ActiveSheet.UsedRange.Rows.Count
Selection.FormulaLocal = "=SVERWEIS(G1;Verweis!$A$1:D"&anzZeilen&";4;0)"

Im Bereich von der SVERWEIS Formel wird ein Fehler angezeigt. Muss ich anzZeilen anders einfügen?

Josef

  


Betrifft: AW: SVerweis Variabler Bereich von: Boris
Geschrieben am: 15.09.2004 08:30:04

Hi Josef,

das liegt nur an dem kaufmännischen & - du musst davor und dahinter Leerzeichen setzen - sonst gibt´s Mecker.

Also so:

Sub aaa()
Dim anzZeilen As Long
anzZeilen = ActiveSheet.UsedRange.Rows.Count
Selection.FormulaLocal = "=SVERWEIS(G1;Verweis!$A$1:D" & anzZeilen & ";4;0)"
End Sub


Allerdings halte ich die Eingrenzung der Zeilenzahl in deinem Fall für überflüssig - schreibe einfach:
Selection.FormulaLocal = "=SVERWEIS(G1;Verweis!$A:$D;4;0)"

Macht performancemäßig Null Unterschied.

Grüße Boris


  


Betrifft: AW: SVerweis Variabler Bereich von: Mac4
Geschrieben am: 15.09.2004 08:31:24

Hallo Josef

ich glaube, VBA hat Dir hier nur die fehlenden Leerzeichen beim "&" krummgenommen! So gehts bei mir:
Selection.FormulaLocal = "=SVERWEIS(G1;Verweis!$A$1:D" & anzZeilen & ";4;0)"

Marc


  


Betrifft: AW: SVerweis Variabler Bereich von: Josef
Geschrieben am: 15.09.2004 08:38:43

Klasse, ich Danke euch :-)

Josef


 

Beiträge aus den Excel-Beispielen zum Thema "SVerweis Variabler Bereich"