Microsoft Excel

Herbers Excel/VBA-Archiv

bedingte Summe

Betrifft: bedingte Summe von: Basti
Geschrieben am: 17.09.2004 13:34:45

hallo,

hab folgende ausgangspositiion:
dicke länge
a 12 100
b 10 50
c 12 80
d 10 70

muss nun summen auflisten der längen, als muss ich ne bedingte summe haben: er soll spalte b nach 12ern durchsuchen und davon die längen addieren, genauso bei 10ern. wie mach ich das???

danke

  


Betrifft: AW: bedingte Summe von: Udo
Geschrieben am: 17.09.2004 13:38:34

Siehe Funktion SUMMEWENN()

Udo


  


Betrifft: =SUMMEWENN(A1:A4;10;B1:B4) oT von: Dieter Maj
Geschrieben am: 17.09.2004 13:41:20




  


Betrifft: AW: =SUMMEWENN(A1:A4;10;B1:B4) oT von: Basti
Geschrieben am: 17.09.2004 13:46:20

danke soweit und was ist, wenn die b spalte variabel sein muss, ich also nicht weiß, welche dicken so auftauchen... wie kann man das abfangen?


  


Betrifft: AW: =SUMMEWENN(A1:A4;10;B1:B4) oT von: Dieter Maj
Geschrieben am: 17.09.2004 13:55:49

Hallo Basti
verstehe deine Frage nicht ganz, du brauchts doch bei anderen Dicken nur den mittleren Parameter austauschen (z.B. aus 10 mach 12) und wenn die Spalten länger werden, pass doch die Range-Adressen an.
Gruß Dieter


  


Betrifft: AW: =SUMMEWENN(A1:A4;10;B1:B4) oT von: Basti
Geschrieben am: 17.09.2004 14:06:40

nene... das problem ist, dass ich vorher meine dicken nicht kenne... kann sie also nicht manuell austauschen... mal wieder das typische excel-problem... zwei variablen... muss quasi spalte b nach werten durchsuchen und dann wenn da identische sind deren werte in c aufaddieren, jetzt klarer?


  


Betrifft: AW: =SUMMEWENN(A1:A4;10;B1:B4) oT von: Dieter Maj
Geschrieben am: 17.09.2004 14:17:55

Hallo basti
das ist alleine mit Formeln nicht anständig zu lösen, da muß ein bischen VBA ran.
Für das habe ich heute keine Zeit(Lust) mehr (Feierabend)
Gruß Dieter


 

Beiträge aus den Excel-Beispielen zum Thema "bedingte Summe"