Microsoft Excel

Herbers Excel/VBA-Archiv

Sortierung

Betrifft: Sortierung von: Frank
Geschrieben am: 17.09.2004 14:07:57

Hallo zusammen,


ich habe folgende Zahlenreihen:

57.695.194.244.384.700
6.789.858.627.319.330
8.795.475.387.573.240
56.783.901.596.069.330
109.695.194.244.384.700
57.695.194.244.384.700

und möchte als Ergbnis:

57
67
87
56
109
57

Also wenn drei Ziffern vor dem ersten Punkt, dann alle ausgeben, wenn
2 Ziffern vor dem Punkt, dann bitte die und besteht nur eine Ziffer dann eine und die nachfolgende nach dem ersten Punkt (wie Reihe 2 im Beispiel)

Kann mir jemand helfen?

Danke und Gruß

Frank

  


Betrifft: AW: Sortierung von: Ramses
Geschrieben am: 17.09.2004 14:15:40

Hallo

probier mal das

Tabelle1
 ABC
157.695.194.244.384.70057 
26.789.858.627.319.33067 
38.795.475.387.573.24087 
456.783.901.596.069.33056 
5109.695.194.244.384.700109 
657.695.194.244.384.70057 
7   
Formeln der Tabelle
B1 : =WENN(FINDEN(".";A1;1)=4;LINKS(A1;3);WENN(FINDEN(".";A1;1)=3;LINKS(A1;2);WENN(FINDEN(".";A1;1)=2;LINKS(WECHSELN(LINKS(A1;3);".";"");2))))
B2 : =WENN(FINDEN(".";A2;1)=4;LINKS(A2;3);WENN(FINDEN(".";A2;1)=3;LINKS(A2;2);WENN(FINDEN(".";A2;1)=2;LINKS(WECHSELN(LINKS(A2;3);".";"");2))))
B3 : =WENN(FINDEN(".";A3;1)=4;LINKS(A3;3);WENN(FINDEN(".";A3;1)=3;LINKS(A3;2);WENN(FINDEN(".";A3;1)=2;LINKS(WECHSELN(LINKS(A3;3);".";"");2))))
B4 : =WENN(FINDEN(".";A4;1)=4;LINKS(A4;3);WENN(FINDEN(".";A4;1)=3;LINKS(A4;2);WENN(FINDEN(".";A4;1)=2;LINKS(WECHSELN(LINKS(A4;3);".";"");2))))
B5 : =WENN(FINDEN(".";A5;1)=4;LINKS(A5;3);WENN(FINDEN(".";A5;1)=3;LINKS(A5;2);WENN(FINDEN(".";A5;1)=2;LINKS(WECHSELN(LINKS(A5;3);".";"");2))))
B6 : =WENN(FINDEN(".";A6;1)=4;LINKS(A6;3);WENN(FINDEN(".";A6;1)=3;LINKS(A6;2);WENN(FINDEN(".";A6;1)=2;LINKS(WECHSELN(LINKS(A6;3);".";"");2))))
 




Gruss Rainer


  


Betrifft: AW: Sortierung von: Reinhard
Geschrieben am: 17.09.2004 14:27:39

Hi Frank,
probier mal für A1:
=WAHL(FINDEN(".";FEST(A1));"";TEIL(FEST(A1);1;1)&TEIL(FEST(A1);3;1);TEIL(FEST(A1);1;2);TEIL(FEST(A1);1;3))
Gruß
Reinhard


  


Betrifft: AW: Sortierung von: Frank
Geschrieben am: 17.09.2004 15:06:55

Super! Funktioniert tadellos!

Danke Reinhard! Danke natürlich auch an Ramses!

Viele Grüsse

Frank


 

Beiträge aus den Excel-Beispielen zum Thema "Sortierung"