Microsoft Excel

Herbers Excel/VBA-Archiv

Wert aus Tabelle ablesen und in Zelle eintragen?

Betrifft: Wert aus Tabelle ablesen und in Zelle eintragen? von: Thorsten
Geschrieben am: 17.09.2004 14:08:10

Hallo,

bin mal gespannt ob ich Antwort bekomme.
Folgendes Problem:
Ich habe eine Matrix erstellt mit Entfernungen zwischen Orten. Die obere Hälfte der Tabelle wird dabei ausgefüllt und die andere transponiert da spiegelsymmetrisch (A,B,C = unterschiedl. Entfernungen).

_____Ort1 Ort2 Ort3
Ort1__x____A____B
Ort2__A____x____C
Ort3__B____C____x

In einer anderen Tabelle möchte ich nun Start- und Zielort (Ort1, Ort2, Ort3) eingeben und die Entfernung soll automatisch in eine Zelle eingetragen werden.

Start__Ziel__Entfernung (soll autom. ausgefüllt werden)
Ort1__Ort2__(hier soll dann "A" stehen)
Ort3__Ort1__"B"

Kann mir jemand helfen?

Gruss
Thorsten

  


Betrifft: AW: Wert aus Tabelle ablesen und in Zelle eintragen? von: ramses
Geschrieben am: 17.09.2004 14:21:17

Hallo

das ein klassischer Fall für SVERWEIS und VERGLEICH

Tabelle1
 ABCDE
1 Ort 1Ort 2Ort 3 
2Ort 1x45 
3Ort 21x6 
4Ort 323x 
5     
6     
7     
8     
9StartOrt 1   
10ZielOrt 3   
11KM5   
12     
Formeln der Tabelle
B11 : =SVERWEIS(B9;A2:D4;VERGLEICH(B10;B1:D1;0)+1;0)
 




Gruss Rainer


  


Betrifft: AW: Wert aus Tabelle ablesen und in Zelle eintragen? von: Jan
Geschrieben am: 17.09.2004 14:36:39

Hi Thorsten,

Auch mit folgender Formel läßt sich das Problem lösen:

=SVERWEIS(B19;A3:K12;WVERWEIS(B20;B2:K13;12;0);0)

Ort 1 Ort 2 Ort 3 Ort 4 Ort 5 Ort 6 Ort 7 Ort 8 Ort 9 Ort 10
Ort 1 x 2 3 4 3 4 5 6 7 5
Ort 2 4 x 3 4 5 6 3 3 3 3
Ort 3 5 3 x 5 3 6 3 3 3 3
Ort 4 6 3 3 x 4 6 3 3 3 3
Ort 5 7 3 3 3 x 6 3 3 3 3
Ort 6 8 3 3 3 3 x 3 3 3 3
Ort 7 9 3 3 4 4 5 x 3 3 3
Ort 8 10 3 3 3 3 3 3 x 3 3
Ort 9 11 3 3 3 3 3 3 3 x 3
Ort 10 12 3 3 3 3 3 3 3 3 x
2 3 4 5 6 7 8 9 10 11
Die Zeile 12 dient für den WVERWEIS zur Rückgabe des jeweiligen Spaltenindex für
den SVERWEIS.

Start Ort 4
Ziel Ort 5
Entfernung 4


Jan



  


Betrifft: AW: Wert aus Tabelle ablesen und in Zelle eintragen? von: Thorsten
Geschrieben am: 17.09.2004 14:44:46

Hallo Rainer, Hallo Jan,

Supergeil! .. Es bedarf noch eines gewissen Feinschliffes, aber auf jeden funktionierts. Ich hab noch ein Problem. Ich will die Summe bilden aus den gefahrenen km und wenn aus der Tabelle kein Wert hervorgeht, dann lautet die Meldung für alle Werte #NV ... wie komm ich da drumrum?

Vielen Dank aber schonmal ... hätte nie gedacht dass das sooo schnell geht. Super Forum!

Gruss
Thorsten


 

Beiträge aus den Excel-Beispielen zum Thema "Wert aus Tabelle ablesen und in Zelle eintragen?"