Microsoft Excel

Herbers Excel/VBA-Archiv

Formelerweiterung bei Wennabfrage

Betrifft: Formelerweiterung bei Wennabfrage von: Thomas
Geschrieben am: 17.09.2004 15:35:11

Hallo Forum,

ich benötige mal wieder eure Hilfe.

Ich habe in der Zelle B12 folgende Formel stehen: =WENN(A12:A33="";"";25000)
wenn in Spalte A13 - A33 nichts eingetragen wird, soll in Spalte B13 - B33 der Wert jeweils um 25000 erhöht werden.
Wenn ich aber z.B. in A 18 ein Wort schreibe sollte in B18 die Zahl 25000 stehen.

Habe mal die Datei zum Testen angehängt
https://www.herber.de/bbs/user/11015.xls

Ich freue mich auf zahlreiche Vorschläge.
Besten Dank im Vorau
Gruß Thomas

  


Betrifft: AW: Formelerweiterung bei Wennabfrage von: Reinhard
Geschrieben am: 17.09.2004 15:51:11

Hi Thomas,
"soll in Spalte B13 - B33 der Wert jeweils um 25000 erhöht werden."
Das geht so nicht, in B13 kann nur ein Wert stehen ODER eine Formel deren Ergebnis man sieht.
Deine Formel stimmt nicht sie wertet nicht A12:A33 aus, sondern einzig A12.
Probiers mal so:
In B12: =WENN(ANZAHL(A12:A33)=0;"";25000)
In B13: =WENN(A13="";C13+25000;25000)
B13 dann bis B33 kopieren.
In Bereich C13:C33 stehen deine "Werte", die du oben erwähnst.
Gruß
Reinhard


  


Betrifft: AW: Formelerweiterung bei Wennabfrage von: Thomas
Geschrieben am: 17.09.2004 16:17:28

Hallo Reinhard,

meine Hochachtung!!

Du hast mir das Wochenende gerettet.
Das war genau das was ich gesucht habe.

Merci

Schönes Wochenende
wünscht Dir Thomas