Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingung für Summe

Betrifft: Bedingung für Summe von: k. reffert
Geschrieben am: 19.09.2004 15:01:31

Hallo, zusammen, habe ein Formelproblem bei dessen Lösung ich eure Hilfe erbitte;
die konkrete Frage habe ich unten in der Tabelle integriert...
Dank vorab an all diejenigen, die mir "auf die Sprünge" helfen, karin

Tabelle1
ABCDEFG
1KZ1KZ2EINHEITENAuswertung:Soll aber herauskommen:
2Aa100KZ1 ist gleich A UND KZ2 enthält a:100630
3Ab600KZ1 ist gleich B UND KZ2 enthält a:0200
4Aa_b530KZ1 ist gleich C UND KZ2 enthält a:7501200
5Bca_1200
6Bc70Die Formel in Zelle E2 liefert leider nur "KZ1 ist gleich A UND KZ2 ist gleich a", entsprechend Zelle E3 und E4; wie muß die (Matrix-)Formel lauten, damit für KZ2 wirklich "enthält a an beliebiger Stelle" berechnet wird? Es müssten dann die Summen 'rauskommen, die ich in F2:F4 mal zum Verdeutlichen stehen hab... (das kleine a in KZ2 habe ich nur zur Verdeutlichung rot formatiert...)
7Bd300
8Cb_a450
9Ca750
10 53000
Formeln der Tabelle
E2 : {=SUMME(WENN(($A$2:$A$9="A")*($B$2:$B$9="a");$C$2:$C$9;0))}
E3 : {=SUMME(WENN(($A$2:$A$9="B")*($B$2:$B$9="a");$C$2:$C$9;0))}
E4 : {=SUMME(WENN(($A$2:$A$9="C")*($B$2:$B$9="a");$C$2:$C$9;0))}
B10 : =ZÄHLENWENN(B2:B9;"*a*")
C10 : =SUMME(C2:C9)

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen Excel Jeanie HTML 3.0 Download
  


Betrifft: AW: Bedingung für Summe von: FP
Geschrieben am: 19.09.2004 15:16:18

Hi Karin,

das geht z.B. so

Tabelle1
 ABCDE
1Aa100A400
2Ab200B400
3Aba300C300
4Bc_a100  
5Bc_b200  
6Ba_b300  
7Bb_c400  
8Cc100  
9Cd200  
10Ca300  
Formeln der Tabelle
E1 : =SUMMENPRODUKT((A1:A10=D1)*ISTZAHL(SUCHEN("*a*";B1:B10))*C1:C10)
E2 : =SUMMENPRODUKT((A2:A11=D2)*ISTZAHL(SUCHEN("*a*";B2:B11))*C2:C11)
E3 : =SUMMENPRODUKT((A3:A12=D3)*ISTZAHL(SUCHEN("*a*";B3:B12))*C3:C12)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Bedingung für Summe von: BerndB
Geschrieben am: 19.09.2004 16:57:59

Hallo Karin,

hier eine direkte Version für Deine Formel:
=SUMME(WENN(($A$2:$A$9="A")*(NICHT(ISTFEHLER(FINDEN("a";$B$2:$B$9))));$C$2:$C$9;0))

a) das Finden("a";B4) liefert die gefundene Stelle oder den Fehler #Wert!
b) Istfehler(Formel(a)) wird WAHR, wenn kein "a" und Falsch, wenn ein "a" enthalten ist
c) deshalb die Umkehrung NICHT, damit die Bedingung zur Berechnung WAHR wird

Gruß
Bernd


  


Betrifft: AW: Bedingung für Summe von: FP
Geschrieben am: 19.09.2004 19:55:12

Hi Bernd,

warum schreibst Du das mir???

Ausserdem ist meine Formel kürzer und man braucht nicht Strg-Shift-Enter drücken ;-)

Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Bedingung für Summe von: k. reffert
Geschrieben am: 19.09.2004 22:46:10

Hallo, ihr lieben, Dank eurer hervorragender Unterstützung klappt es jetzt, beide Varianten - SUMMENPRODUKT als auch SUMME - bringen das gesuchte Ergebnis. Allein mit
der Excel-Hilfe kann man da doch nicht drauf kommen? Das war ein echtes Aha-Erlebnis, als ich deine Formel (@Franz) mal zerlegt hatte, dass nämlich zB #WERT mal FALSCH gleich Null ist, respektive WAHR mal WAHR gleich Eins bzw. FALSCH mal WAHR gleich Null ist...
Nochmals allerherzlichsten Dank euch beiden, Bernd und Franz!!! Gruss, Karin

Tabelle1
 ABCDEFG
1KZ1KZ2EINHEITENAuswertung:Dank eurer Hilfe jetzt:
2Aa100KZ1 ist gleich A UND KZ2 enthält a:100630630
3Ab600KZ1 ist gleich B UND KZ2 enthält a:0200200
4Aa_b530KZ1 ist gleich C UND KZ2 enthält a:75012001200
5Bca_1200    
6Bc70    
7Bd300    
8Cb_a450    
9Ca750    
10       
Formeln der Tabelle
F2 : {=SUMMENPRODUKT((SpA="A")*ISTZAHL(SUCHEN("*a*";SpB;1))*SpC)}
G2 : {=SUMME(WENN((SpA="A")*(NICHT(ISTFEHLER(FINDEN("a";SpB))));SpC;0))}
F3 : {=SUMMENPRODUKT((SpA="B")*ISTZAHL(SUCHEN("*a*";SpB;1))*SpC)}
G3 : {=SUMME(WENN((SpA="B")*(NICHT(ISTFEHLER(FINDEN("a";SpB))));SpC;0))}
F4 : {=SUMMENPRODUKT((SpA="C")*ISTZAHL(SUCHEN("*a*";SpB;1))*SpC)}
G4 : {=SUMME(WENN((SpA="C")*(NICHT(ISTFEHLER(FINDEN("a";SpB))));SpC;0))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



  


Betrifft: SUMMENPRODUKT, war: Bedingung für Summe von: k. reffert
Geschrieben am: 19.09.2004 23:04:57

Huch, Franzl,
das wichtigste habe ich überlesen, daß ich mir nämlich die Matrix-Klammern sparen kann... Hab's ausprobiert, du hast recht, wunderbar!!!
Dank recht schön und Gute Nacht,
Karin


 

Beiträge aus den Excel-Beispielen zum Thema "Bedingung für Summe"