Denksport zum Wochenende wegen Bezügen

Bild

Betrifft: Denksport zum Wochenende wegen Bezügen von: Lars
Geschrieben am: 04.02.2005 15:49:22

Also ich habe nun folgendes. (jan kennt das schon bei mir... ;) )

Ich habe 5 tabellenblätter, speichere sie ab, speichere sie unter neuem namen und kopiere eine liste vom letzen blatt zum ersten, um den nächsten tag zu beginnen.
Nun passiert aber folgendes:
der Verweis
=WENN(A2=0;"";SVERWEIS(A2; 'Kanban Liste'!$A$2:$G$40; 5; FALSCH))
wird zu einem schönen
=WENN(#BEZUG!=0;"";SVERWEIS(#BEZUG!; 'Kanban Liste'!$A$2:$G$40; 5; FALSCH))

Kopieren tue ich mit diesem Skripteil:


Sub speichern()
ActiveWorkbook.Save
ActiveWorkbook.SaveAs Filename:="U:\Kanban\K" & Date + 1
Worksheets("Übergabe nächster Tag").Range("A:B").Select
Selection.Cut
Sheets("Eingangsliste").Select
Worksheets("Eingangsliste").Range("A:B").Select
ActiveSheet.Paste
End Sub


Hinbekommen hab ich solche Skripte überhaupt erst mit C-Kenntnissen und viel Hilfe von Euch hier. :)
es gab viele gute ideen! :)
Also vielleicht fällt euch hier auch noch etwas ein.
Gruß Lars
Bild


Betrifft: AW: Denksport zum Wochenende wegen Bezügen von: Josef Ehrensberger
Geschrieben am: 04.02.2005 16:01:29

Hallo Lars!

Sollte eigentlich reichen!

Sub speichern()
ActiveWorkbook.Save
ActiveWorkbook.SaveAs Filename:="U:\Kanban\K" & Date + 1
Worksheets("Übergabe nächster Tag").Range("A:B").Cut _
Worksheets("Eingangsliste").Range("A1")
End Sub



Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Denksport zum Wochenende wegen Bezügen von: Lars
Geschrieben am: 04.02.2005 16:13:00

Japp, zum kopieren reicht das, aber meine Bezugsfrage ist noch net geklärt, weil immernoch dann überall eine dickes fettes: #BEZUG! steht... s.o.


Bild


Betrifft: AW: Denksport zum Wochenende wegen Bezügen von: Werner Oertli
Geschrieben am: 04.02.2005 16:17:37

Grüezi Lars

Ein #BEZUG entsteht, wenn die Zelle dieses Bezugs z.B. Gelöscht worden ist.

Was steht den in A2?

Gruss Werner


Bild


Betrifft: AW: Denksport zum Wochenende wegen Bezügen von: Lars
Geschrieben am: 04.02.2005 16:20:33

||der Verweis
||=WENN(A2=0;"";SVERWEIS(A2; 'Kanban Liste'!$A$2:$G$40; 5; FALSCH))
||wird zu einem schönen
||=WENN(#BEZUG!=0;"";SVERWEIS(#BEZUG!; 'Kanban Liste'!$A$2:$G$40; 5; FALSCH))

Aus dem Verweis oben wird der darunter nach dem automatischen kopieren.


Bild


Betrifft: nachtrag dazu: von: Lars
Geschrieben am: 04.02.2005 16:25:56

Sorry, wenn das schroff klang.
Bin nur etwas in zeitdruck, das Problem selbst hat zeit. Bin gleich auch im Wochenende. :)
Insofern frohes karnevalistisches Treiben allen, die sich noch mit dem Problem beschäftigen, oder auch nicht! :)

Und der sverweis zeigt leider aufs A2, das ersetzt wird. kann man verhindern, dass er das so meckernd annimmt?

Gruß Lars


Bild


Betrifft: AW: nachtrag dazu: von: Werner Oertli
Geschrieben am: 04.02.2005 16:31:44

Hallo Lars

Du kopierst die Formel in ein anderes Worksheet. Da findet er den Bezug nicht mehr.
Wenn Du die Zelle schützt "Ausgeblendet" übernimmt er nur den Wert und nicht die Formel

Gruss Werner


Bild


Betrifft: AW: nachtrag dazu: von: Lars
Geschrieben am: 04.02.2005 16:37:10

Hm, ich glaube, wir reden aneinander vorbei. :)
Die formel steht da schon vorher und wird nicht eingefügt. Sie seht in spalte C und list aus A aus. Nur diesmal ändere ich das A in ein anderes A und das gefällt ihm nicht´.

Habe trotzdem mal das Ausblenden versucht, hat nur nix geholfen. Er meldet trotzdem noch fröhlich #BEZUG!
Schade.


Bild


Betrifft: AW: Denksport zum Wochenende wegen Bezügen von: Dominic
Geschrieben am: 04.02.2005 16:44:51

Hallo,

Ich schließe mich Werner Oertli an, irgendetwas passiert mit A2.

Aber ein Ausweg könnte sein:


Sub test()
Dim a As Long
Dim b As Long
Dim str As String
For a = 1 To Sheets("Übergabe nächster Tag").Cells(1, 1).End(xlDown).Row
    For b = 1 To 2
        With Sheets("Eingangsliste")
            str = Sheets("Übergabe nächster Tag").Cells(a, b).FormulaLocal
            .Cells(a, b) = str
        End With
    Next b
Next a
End Sub



gruß
Dominic


Bild


Betrifft: Danke, ist gelöst! :) von: Lars
Geschrieben am: 07.02.2005 09:25:44

Hui, das klappt. prima.
Deine Prozedur als Übergabe benannt und private gemacht
und so ins neue blatt speichern



Sub speichern()
    ActiveWorkbook.Save
    ActiveWorkbook.SaveAs Filename:="U:\K" & Date + 1 & ".xls"
    Sheets("Eingangsliste").Select
    Columns("A:B").Select
    Selection.Clear
    Uebergabe
End Sub


Herzlichen Dank, ihr habt wieder klasse geholfen


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Denksport zum Wochenende wegen Bezügen"