Daten auswerten

Bild

Betrifft: Daten auswerten von: simon
Geschrieben am: 08.02.2005 20:29:52

Hallo zusammen,

Hab ein kleines Problem, irgendwie komm ich selber nicht drauf.

habe eine Excel Tabelle in der Ich Produkte Eintrage wann sie gekauft wurden.

Eigentlich sinds nur 3 Spalten. Spalte A "Datum" Spalte B "Produkt" Spalte C "Preis"

Jetzt möchte ich die Daten so Filtern das ich sehe wieviel Produkte ich im Monat Januar, Februar, ... gekauft habe, und wie hoch die ausgaben pro Monat waren.

Geht das evtl. mit einer wenn Funktion, oder gibts da einen Prof. Filter
Bedanke mich schon mal für eure Mühe

Bild


Betrifft: AW: Daten auswerten von: Jemp
Geschrieben am: 08.02.2005 20:44:31

Hallo

Mach dir eine zusätzliche Spalte mit dem Monat und bau dir eine Pivottabelle, das ist das einfachste.

Gruss

Jemp


Bild


Betrifft: AW: Daten auswerten von: Josef Ehrensberger
Geschrieben am: 08.02.2005 20:49:36

Hallo Simon!

Etwa so?
Tabelle1
 ABCDEFGH
1DatumProduktPreis  MonatAnzahlSumme
205.01.2005Produkt 1€ 1,00  Jänner6€ 788,00
312.01.2005Produkt 2€ 125,00  Februar3€ 458,00
417.01.2005Produkt 3€ 75,00  März0€ 0,00
521.01.2005Produkt 4€ 185,00  April0€ 0,00
625.01.2005Produkt 5€ 257,00  Mai0€ 0,00
730.01.2005Produkt 6€ 145,00  Juni0€ 0,00
801.02.2005Produkt 7€ 95,00  Juli0€ 0,00
903.02.2005Produkt 8€ 148,00  August0€ 0,00
1007.02.2005Produkt 9€ 215,00  September0€ 0,00
11     Oktober0€ 0,00
12     November0€ 0,00
13     Dezember0€ 0,00
Formeln der Tabelle
G2 : =SUMMENPRODUKT((MONAT(A2:A100)=ZEILE(A1))*(A2:A100<>"")*1)
H2 : =SUMMENPRODUKT((MONAT(A2:A100)=ZEILE(A1))*(C2:C100))
G3 : =SUMMENPRODUKT((MONAT(A3:A101)=ZEILE(A2))*(A3:A101<>"")*1)
H3 : =SUMMENPRODUKT((MONAT(A3:A101)=ZEILE(A2))*(C3:C101))
G4 : =SUMMENPRODUKT((MONAT(A4:A102)=ZEILE(A3))*(A4:A102<>"")*1)
H4 : =SUMMENPRODUKT((MONAT(A4:A102)=ZEILE(A3))*(C4:C102))
G5 : =SUMMENPRODUKT((MONAT(A5:A103)=ZEILE(A4))*(A5:A103<>"")*1)
H5 : =SUMMENPRODUKT((MONAT(A5:A103)=ZEILE(A4))*(C5:C103))
G6 : =SUMMENPRODUKT((MONAT(A6:A104)=ZEILE(A5))*(A6:A104<>"")*1)
H6 : =SUMMENPRODUKT((MONAT(A6:A104)=ZEILE(A5))*(C6:C104))
G7 : =SUMMENPRODUKT((MONAT(A7:A105)=ZEILE(A6))*(A7:A105<>"")*1)
H7 : =SUMMENPRODUKT((MONAT(A7:A105)=ZEILE(A6))*(C7:C105))
G8 : =SUMMENPRODUKT((MONAT(A8:A106)=ZEILE(A7))*(A8:A106<>"")*1)
H8 : =SUMMENPRODUKT((MONAT(A8:A106)=ZEILE(A7))*(C8:C106))
G9 : =SUMMENPRODUKT((MONAT(A9:A107)=ZEILE(A8))*(A9:A107<>"")*1)
H9 : =SUMMENPRODUKT((MONAT(A9:A107)=ZEILE(A8))*(C9:C107))
G10 : =SUMMENPRODUKT((MONAT(A10:A108)=ZEILE(A9))*(A10:A108<>"")*1)
H10 : =SUMMENPRODUKT((MONAT(A10:A108)=ZEILE(A9))*(C10:C108))
G11 : =SUMMENPRODUKT((MONAT(A11:A109)=ZEILE(A10))*(A11:A109<>"")*1)
H11 : =SUMMENPRODUKT((MONAT(A11:A109)=ZEILE(A10))*(C11:C109))
G12 : =SUMMENPRODUKT((MONAT(A12:A110)=ZEILE(A11))*(A12:A110<>"")*1)
H12 : =SUMMENPRODUKT((MONAT(A12:A110)=ZEILE(A11))*(C12:C110))
G13 : =SUMMENPRODUKT((MONAT(A13:A111)=ZEILE(A12))*(A13:A111<>"")*1)
H13 : =SUMMENPRODUKT((MONAT(A13:A111)=ZEILE(A12))*(C13:C111))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Daten auswerten von: simon
Geschrieben am: 08.02.2005 21:11:06

hallo,

Auf das Forum ist einfach verlass,
Ja genau sowas Habe ich gesucht, Josef könntest du mir nochmal die Formeln von Spalte G und H schicken, kann sie nicht ganz erkennen. aber wenn ich das richtig seh müsste das die Formel Summenprodukt sein, und dann einfach meine Tabellen Bereich markieren ?!

Mit freundlichem Gruß Simon


Bild


Betrifft: AW: Daten auswerten von: Josef Ehrensberger
Geschrieben am: 08.02.2005 21:29:05

Hallo Simon!

Hier nochmal die Foprmeln für Zeile 2.
Du kannst sie einfach runterkopieren!


G2 : =SUMMENPRODUKT((MONAT($A$2:$A$100)=ZEILE(A1))*($A$2:$A$100<>"")*1)
H2 : =SUMMENPRODUKT((MONAT($A$2:$A$100)=ZEILE(A1))*($C$2:$C$100))



Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: danke super, auf die Formel wäre ich ja nie gekomm von: simon
Geschrieben am: 08.02.2005 21:44:20

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Daten auswerten"