Flexible SUMMEWENN-Funktion

Bild

Betrifft: Flexible SUMMEWENN-Funktion
von: Florian Hass
Geschrieben am: 15.02.2005 09:45:24
Hallo liebes Forum,
ich brauche Eure Hilfe. Ich möchte die SUMMEWENN-Funktion nutzen, um in einem Ausgabeblatt Daten aus einem Datenblatt zu addieren (über einen Index). Allerdings möchte ich den Summe_Bereich flexibilisieren, d.h. keinen fixen Spaltenbezug angeben. Z.Zt. stehen in dem Datenblatt Überschriften, auf die ich mich beziehen möchte, die ich allerdings über VBA in die A1-Bezugsart umwandeln und so unter Umständen nutzen könnte. Zu unklar formuliert??
Bitte helft mir!!
Grüße, Florian

Bild

Betrifft: AW: Flexible SUMMEWENN-Funktion
von: Hübi
Geschrieben am: 15.02.2005 09:56:24
Hi Florian,
ich würde mit Bereichs-Namen arbeiten und mit BEREICH.VERSCHIEBEN() die "Position" vorgeben/ändern.
Das hat den Vorteil, dass die Formel nicht unnötig verlängert wird.
Gruß Hübi
Bild

Betrifft: AW: Flexible SUMMEWENN-Funktion
von: Florian
Geschrieben am: 15.02.2005 10:27:55
Danke Hübi für Deine Antwort.
Und was ist, wenn ich keine Bereichs-Namen vergeben möchte? Gibt es noch eine Alternative?
Gruß, Florian
Bild

Betrifft: AW: Flexible SUMMEWENN-Funktion
von: Hübi
Geschrieben am: 15.02.2005 10:48:31
Hi Florian,
dann geht es mit INDIREKT().
Hier ein ganz einfaches Bspl.
Tabelle1
 ABCDEFG
1SuchspalteWert 1Wert 2Wert 3Sucheaus Spalte 
2a147bCD
3b258121620
4c369   
5b101112   
Formeln der Tabelle
E3 : =SUMMEWENN(A:A;E2;B:B)
F3 : =SUMMEWENN(A:A;E2;INDIREKT(F2&":"&F2))
G3 : =SUMMEWENN(A:A;E2;INDIREKT(G2&":"&G2))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hübi
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Flexible SUMMEWENN-Funktion"