Sortierformel

Bild

Betrifft: Sortierformel von: Conny
Geschrieben am: 16.02.2005 16:43:21

Hallo nochmal!

Zum unten angehangenen Text hat sich doch noch eine Frage ergeben:

Können die Datensätze anschließend noch sortiert werden? Gibt's da auch eine Formel, die das automatisiert?

Vielen Dank im Voraus!

die Conny



vorheriges Problem (aber schon gelöst):

Ich habe mal eine Frage zum arbeiten mit Zeichenketten.
Es dreht sich darum, Bezeichnungen ein Index zuzuweisen.

Ich habe folgende Aufgabe:
In der ersten Spalte einer Tabelle werden verschiedene Bezeichnungen eingetragen. Die Bezeichnungen sind alle 5 Zeichen lang und es gibt insegsamt 30 verschiedene. Die Einträge folgen keiner festen Ordnung, sie sind bei jeder Anwendung in einer anderen Reihenfolge. Es müssen auch nicht immer alle möglichen Bezeichnungen auftauchen.
Da die Bezeichnungen aber auch doppelt oder mehrmals auftreten können, soll an die Zeichenkette in einer zusätzlichen Spalte ein Index angehangen werden.

Ich mach mal schnell ein Beispiel, wie's aussehen soll:

Spalte 1 Spalte 2 (Ergebnis)
AA/AA AA/AA1
AA/BA AA/BA1
AA/BV AA/BV1
AA/AA AA/AA2
AA/AA AA/AA3
AA/XY AA/XY1
AA/BV AA/BV2
...

Ich suche am liebsten nach einer Lösung, die kein VBA benötigt. Es soll ganz einfach und fix gehen. Wenn's aber nicht anders geht, dann erstell ich auch was in VBA.

Könnt ihr mir da weiterhelfen? Ich habe schon ein bisschen in der Recherche nachgesehen, aber noch nix konkretes finden können.

die Conny

Bild


Betrifft: AW: Sortierformel von: ransi
Geschrieben am: 16.02.2005 17:34:45

hallo conny

wäre das eine lösung?

 
 AB
1AA/AAAA/AA1
2AA/BAAA/BA1
3AA/BVAA/BV1
4AA/AAAA/AA2
5AA/AAAA/AA3
6AA/XYAA/XY1
7AA/BVAA/BV2
Formeln der Tabelle
B1 : =A1&ZÄHLENWENN(A1;A1)
B2 : =A2&ZÄHLENWENN($A$1:A2;A2)
B3 : =A3&ZÄHLENWENN($A$1:A3;A3)
B4 : =A4&ZÄHLENWENN($A$1:A4;A4)
B5 : =A5&ZÄHLENWENN($A$1:A5;A5)
B6 : =A6&ZÄHLENWENN($A$1:A6;A6)
B7 : =A7&ZÄHLENWENN($A$1:A7;A7)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

ransi


Bild


Betrifft: AW: Sortierformel von: HermannZ
Geschrieben am: 16.02.2005 18:00:30

Hallo Conny,

meinst du das so???

Beispiel;

A1
 AB
326  
327Einträge auf doppelte prüfen und durchnummerieren 
328  
329AA/AAAA/AA / 1
330AA/BBAA/BB / 1
331AA/BVAA/BV / 1
332AA/AAAA/AA / 2
333AA/AAAA/AA / 3
334AA/XYAA/XY / 1
335AA/BVAA/BV / 2
336  
337  
338 Formel nach
339 unten kopieren
340  
Formeln der Tabelle
B329 : {=WENN(A329<>"";WENN(ZÄHLENWENN($A$117:$A$125;A$125:$A329)>1;A329&" / "&ZÄHLENWENN($A$117:A329;A329);A329);"")}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Gruppe von OptionsButton kontrolieren"