Konvertierung

Bild

Betrifft: Konvertierung
von: John
Geschrieben am: 22.02.2005 16:27:36
hallo,
ich habe ein Problem. Ich bekomme von meinem Großhändler eine Preisliste. Leider sind in manchen zeilen die Werte in Monat+Wert oder Wert+Monat.
Hier ein Beispiel:
31,67
70,13
01. Sep (statt 01.09)
26. Dez (statt 26.12)
15,78
23. Jan (statt 23.01
33,05
33,05
Jun 89 (statt 06.89)
10. Jul (statt 10.07)
Okt 82 (statt 10.82)
Nov 50 (statt 11.50)
usw..
Wie kann ich diesses Problem lösen. Es sind ja verschiedene Formate in den Felder vorhanden. Hoffe es kann mir jemand helfen.
Gruß,
John

Bild

Betrifft: AW: Konvertierung
von: UweD
Geschrieben am: 22.02.2005 17:15:51
Hallo

per Makro ginge es.
Versuch mal das hier

Sub extra() 'Dieses Makro ausführen
    Dim Z
    ' Bereich vorher markieren
    For Each Z In Selection
        Z.Value = Datum_raus(Z.Text)
    Next
End Sub


Function Datum_raus(Wert$)
    Wert = Application.Substitute(UCase(Wert), "JAN", "01")
    Wert = Application.Substitute(UCase(Wert), "FEB", "02")
    Wert = Application.Substitute(UCase(Wert), "MÄR", "03")
    Wert = Application.Substitute(UCase(Wert), "APR", "04")
    Wert = Application.Substitute(UCase(Wert), "MAY", "05")
    Wert = Application.Substitute(UCase(Wert), "JUN", "06")
    Wert = Application.Substitute(UCase(Wert), "JUL", "07")
    Wert = Application.Substitute(UCase(Wert), "AUG", "08")
    Wert = Application.Substitute(UCase(Wert), "SEP", "09")
    Wert = Application.Substitute(UCase(Wert), "OKT", "10")
    Wert = Application.Substitute(UCase(Wert), "NOV", "11")
    Wert = Application.Substitute(UCase(Wert), "DEZ", "12")
    Wert = Application.Substitute(Wert, " ", ",")
    Wert = Application.Substitute(Wert, ".", ",")
    Wert = Application.Substitute(Wert, ",,", ",")
    Datum_raus = Wert
End Function

Bild

Betrifft: AW: Konvertierung
von: John
Geschrieben am: 22.02.2005 19:18:41
Hallo,
leider sturzt Excell wenn ich dieses Makro benutzte. Es sind um die 32000 Zeilen. Und ich sehe auch das es nur bei Datum austauscht von die Monatszahlen vorne sind
Beispiel: 01. Sep (01.09)
aber nicht bei Sep.01
Muss man da Gross und Kleinschreibung beachten?
Gru,
John
Bild

Betrifft: AW: Konvertierung
von: John
Geschrieben am: 23.02.2005 00:34:16
Hallo,
leider sturzt Excell wenn ich dieses Makro benutzte. Es sind um die 32000 Zeilen. Und ich sehe auch das es nur bei Datum austauscht von die Monatszahlen vorne sind
Beispiel: 01. Sep (01.09)
aber nicht bei Sep.01
Muss man da Gross und Kleinschreibung beachten?
Gru,
John
Bild

Betrifft: AW: Konvertierung
von: th.heinrich
Geschrieben am: 22.02.2005 17:33:59
hi John,
bringt Dich dies weiter?
Tabelle2
 FG
2131,6731,67
2270,1370,13
2301. Sep01.09
2426. Dez26.12
Formeln der Tabelle
G21 : =WENN(F21>1462;TEXT(F21;"TT.MM");F21)
G22 : =WENN(F22>1462;TEXT(F22;"TT.MM");F22)
G23 : =WENN(F23>1462;TEXT(F23;"TT.MM");F23)
G24 : =WENN(F24>1462;TEXT(F24;"TT.MM");F24)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

funzzt aber nur bis preise <1462
gruss thomas
Bild

Betrifft: ergaenzung
von: th.heinrich
Geschrieben am: 22.02.2005 18:05:18
hallo John,
das mit 1462 ist ein extrembeispiel, weil es dem Datum des 1.1.1904 entspricht und ich nehme nicht an, dass Dein lieferant so spaet liefert ;-))
Du kannst die zahl also wesentlich erhoehen; der 1.1.1950 ist als serielle zahl = 18568.
gruss thomas
Bild

Betrifft: AW: ergaenzung
von: John
Geschrieben am: 22.02.2005 19:07:54
Hallo,
dies hat mich schon viel weitergeholfen. Aber trotzdem bei:
G24
funktioniert dieses nicht. Es funktioniert nur bei Zellen die TT:MM aufweißen.
Wie soll ich es machen bei MM:JJ?
Kann man diese irgend wie im Makros abfragen?
Weil es ja ünterschiedlich auftaucht (Zellen MM:TT und TT:MM)
Gruß,
John
Bild

Betrifft: AW: ergaenzung
von: th.heinrich
Geschrieben am: 22.02.2005 20:27:32
hallo John,
G24?? was steht da drin, am besten du laedst ein übersichtliches beispiel auf den server.
vorher noch ein versuch.
Tabelle1
 ABC
1Jun 89statt 06.89)01.06.89
210. Julstatt 10.07)10.07.05
326,56 26,56
Formeln der Tabelle
C1 : =WENN(A1>18624;TEXT(A1;"TT.MM.JJ");A1)
C2 : =WENN(A2>18624;TEXT(A2;"TT.MM.JJ");A2)
C3 : =WENN(A3>18624;TEXT(A3;"TT.MM.JJ");A3)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
Bild

Betrifft: AW: ergaenzung
von: John
Geschrieben am: 23.02.2005 00:48:01
hallo,
leider kann ich keine Dateien hochladen, obwohl es zip. bzw. xls datein sind
Gruß,
John
Bild

Betrifft: AW: ergaenzung
von: Reinhard
Geschrieben am: 23.02.2005 01:06:06
Hi John,
ändere den Dateinamen der xls ab in was kurzes wie Mappe.xls, keine Ö, Leerzeichen und sontsiger ram benutzen und kopier sie nahe an c:\ heran.
Und warum zip? was sollen wir nmit ´ner Riesendatei??
Kleine xls als Beispiel ist gefragt. Sollte es doch ein Dateigrößenproblem sein so ist es einfach die Datei mit ner Schleife aufzupusten.
Gruß
Reinhard
Bild

Betrifft: AW: ergaenzung
von: John
Geschrieben am: 23.02.2005 03:58:03
Hallo,
also der Upload hat endlich geklappt. Hier der Link dazu.
https://www.herber.de/bbs/user/18558.xls

Ich denke Sie können mit dem was anfangen.
Gruß,
John
Bild

Betrifft: So eine Liste sah ich noch nie *staun*
von: Reinhard
Geschrieben am: 23.02.2005 04:36:25
Hi John,
welchen Preis soll ich denn aus "10. Jul" oder "Okt 82" oder Nov 50 bilden?
Tabellenblattname: Tabelle1
        C      |        D         |        E         |            F             |                                     G                                      |    H    |       I       |          J           | 
 1| Hersteller |          Familie |           Klasse |                Subklasse |                                                                Bezeichnung |   Preis | Verfügbarkeit | Vorauss. Lieferdatum | 
 2|            |                  |                  |                          |                                                                            |         |               |                      | 
 3|        IBM |          Zubehör |    Systemzubehör |       Kabel - Kabel >80V |                                    IBM Stecker - Y ext. Tastatur/Maus f.TP |   31,67 |          Nein |           28.02.2005 | 
 4|      CANON | Dienstleistungen | Reparaturservice |              Ersatzteile |                                            SP/CA Akku NICD NB-150 BJ-10/20 |   70,13 |          Nein |           23.03.2005 | 
 5|      CANON |          Zubehör |   Druckerzubehör | Sonstiges Druckerzubehör |            CANON BC-01 Druckkopf mit Tintentank    schwarz/BJ10/20/ca 550S | 26. Dez |            Ja |                      | 
 6|      CANON |          Zubehör |   Druckerzubehör |           Tintenpatronen |                            CANON BJI-642 Tintentank schwarz/BJ3xx/ ca 790S |   15,78 |            Ja |                      | 
 7|      CANON |          Zubehör |   Druckerzubehör |           Tintenpatronen |                     CANON BJI-643BK Tintentank schwarz/     BJC8xx/ca 700S | 23. Jan |            Ja |                      | 
 8|      CANON |          Zubehör |   Druckerzubehör |           Tintenpatronen |                     CANON BJI-643C Tintentank cyan/         BJC8xx/ca 470S |   33,05 |            Ja |                      | 
 9|      CANON |          Zubehör |   Druckerzubehör |           Tintenpatronen |                     CANON BJI-643M Tintentank magenta/      BJC8xx/ca 470S |   33,05 |            Ja |                      | 
10|      CANON |          Zubehör |   Druckerzubehör |           Tintenpatronen |                     CANON BJI-643Y Tintentank gelb/         BJC8xx/ca 470S |   29,74 |            Ja |                      | 
11|      CANON |          Zubehör |   Druckerzubehör |                   Folien | CANON CF-102 Overhead-Folie/A4/50 Bl/BJ-30/BJC außer -8xx/Compri/Multipass |   26,66 |          Nein |           23.03.2005 | 
12|      CANON |          Zubehör |   Druckerzubehör |           Tintenpatronen |            CANON BJI-101 Tintentank schwarz/       Compri CN600/BN200C/60S |  Jun 89 |          Nein |           23.03.2005 | 
13|         HP |          Zubehör |   Druckerzubehör | Sonstiges Druckerzubehör |      HP Tintenpatrone schwarz ThinkJet/Plus/ QuietJet/Plus f. Normalpapier | 10. Jul |            Ja |                      | 
14|         HP |          Zubehör |   Druckerzubehör |           Tintenpatronen |        HP Tintenpatrone schwarz ThinkJet/Plus/ QuietJet/Plus f. Jet-Papier |  Okt 82 |          Nein |           22.02.2005 | 
15|         HP |          Zubehör |   Druckerzubehör |           Tintenpatronen |                HP Tintenpatrone rot ThinkJet/QuietJet/ Plus/ f. Jet-Papier |  Nov 50 |            Ja |                      | 
16|         HP |          Zubehör |   Druckerzubehör | Sonstiges Druckerzubehör |                                   HP Tintenpatrone blau ThinkJet/QuietJet/ |  Nov 50 |          Nein |           18.02.2005 | 
17|         HP |          Zubehör |   Druckerzubehör |   Papier >A3 Einzelblatt |                             HP Premium Tintenstrahlpapier A4 200 Bl 92g/m² |   16,85 |          Nein |           14.02.2005 | 
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html 

Bild

Betrifft: AW: So eine Liste sah ich noch nie *staun*
von: UweD
Geschrieben am: 23.02.2005 10:01:15
Hallo
Ich hab mein Makro auf deine Beispieltabelle abgeändert.
https://www.herber.de/bbs/user/18568.xls
Gruß UweD
Bild

Betrifft: AW: So eine Liste sah ich noch nie *staun*
von: John
Geschrieben am: 23.02.2005 10:49:44
Hallo Reinhard,
erstmals Vielen Dank für die mühe.
Es müssen folgendes gebildet werden:
23.Jan ( 23.01)
10.Juli (10.07)
Okt. 82 ( 10.82)

Nov. 50 (11.50) usw.

Wie ich das sehe nimmt er die Zahlen von 01-12 die Monate statt die Zahlen. Und die sollen geändert werden. Der Rest bleibt gleich.
Gruß,
John
Bild

Betrifft: AW: So eine Liste sah ich noch nie *staun*
von: John
Geschrieben am: 23.02.2005 11:13:09
Hallo Uwe,
Vielen Dank nochmals für deine Hilfe. Das klappt ja jetzt. Das war eine Sehr Sehr große hilfe.
Gruß,
John
Bild

Betrifft: geschlossen
von: erledigt
Geschrieben am: 23.02.2005 12:07:06
ot
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Konvertierung"