Herbers Excel-Forum - das Archiv

Zellinhalte splitten

Bild

Betrifft: Zellinhalte splitten
von: Dirk

Geschrieben am: 22.02.2005 21:06:12

Hallo Zuaammen,
hätte hier mal eine kleine Herausforderung an Euch! ;-)
Habe eine Datei, welche ca. wie folgt aussieht:
https://www.herber.de/bbs/user/18544.xls
die in Spalte B befindlichen Texte sollen getrennt werden, d.h.
die Zahlen sollen in eine Spalte und die Textfolgen sollen in eine
eigene Spalte -
sollte wie folgende Datei zum Schluß aussehen

Die Datei https://www.herber.de/bbs/user/18545.xls wurde aus Datenschutzgründen gelöscht

Es ist halt eine Datei mit mehreren tausenden Datensätzen.
Die Zahlen können von 0 bis 999 reichen und die Buchstaben
sind maximal dreistellig. Der erste Buchstabe gleich nach der Zahl
kann nur A - B - C sein. Der letzte oder die letzten beiden Buchstaben
können nur X - Y - Z sein.
Ich hoffe es ist relativ einfach und wäre Euch für jeden Tipp dankbar.
Viele Grüße Dirk
Bild

Betrifft: AW: Zellinhalte splitten
von: andre
Geschrieben am: 22.02.2005 21:31:40
Hallo Dirk,
schaue mal hier:
http://www.excelformeln.de/formeln.html?welcher=100
den Rest bekommst Du auch gebacken oder?
Bild

Betrifft: AW: Zellinhalte splitten
von: Heinz Ulm

Geschrieben am: 22.02.2005 21:34:16
Hallo Dirk,
hier mal meine Lösung:
Tabelle1
 ABCD
13350069BY9BY
246465645BX45BX
31547122CZ2CZ
49325451AZ1AZ
51474451CZZ1CZZ
Formeln der Tabelle
C1 : =TEIL(B1;1;WENN(UND(CODE(TEIL(B1;3;1))<=57;CODE(TEIL(B1;3;1))>=48);3;WENN(UND(CODE(TEIL(B1;2;1))<=57;CODE(TEIL(B1;2;1))>=48);2;1)))*1
D1 : =RECHTS(B1;LÄNGE(B1)-LÄNGE(C1))
C2 : =TEIL(B2;1;WENN(UND(CODE(TEIL(B2;3;1))<=57;CODE(TEIL(B2;3;1))>=48);3;WENN(UND(CODE(TEIL(B2;2;1))<=57;CODE(TEIL(B2;2;1))>=48);2;1)))*1
D2 : =RECHTS(B2;LÄNGE(B2)-LÄNGE(C2))
C3 : =TEIL(B3;1;WENN(UND(CODE(TEIL(B3;3;1))<=57;CODE(TEIL(B3;3;1))>=48);3;WENN(UND(CODE(TEIL(B3;2;1))<=57;CODE(TEIL(B3;2;1))>=48);2;1)))*1
D3 : =RECHTS(B3;LÄNGE(B3)-LÄNGE(C3))
C4 : =TEIL(B4;1;WENN(UND(CODE(TEIL(B4;3;1))<=57;CODE(TEIL(B4;3;1))>=48);3;WENN(UND(CODE(TEIL(B4;2;1))<=57;CODE(TEIL(B4;2;1))>=48);2;1)))*1
D4 : =RECHTS(B4;LÄNGE(B4)-LÄNGE(C4))
C5 : =TEIL(B5;1;WENN(UND(CODE(TEIL(B5;3;1))<=57;CODE(TEIL(B5;3;1))>=48);3;WENN(UND(CODE(TEIL(B5;2;1))<=57;CODE(TEIL(B5;2;1))>=48);2;1)))*1
D5 : =RECHTS(B5;LÄNGE(B5)-LÄNGE(C5))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Heinz
Bild

Betrifft: AW: Zellinhalte splitten
von: Reinhard

Geschrieben am: 22.02.2005 22:17:57
Hi Heinz,
leider hat deine Tabelle , genau wie meine *gg, ein Problem, nämlich dann wenn die Buchstaben einstelig werden also bei
9B anstatt 9BY
Tabellenblattname: IST
A    |   B   |  C  |  D  |    E     |
1| 335006 |   9BY |   9 |  BY |          |
2| 464656 |  45BX |  45 |  BX |          |
3| 154712 |    9B |  9B |     | <<< Hier |
4| 932545 |   1AZ |   1 |  AZ |          |
5| 147445 |  1CZZ |   1 | CZZ |          |
6| 454546 | 100AX | 100 |  AX |          |
Benutzte Formeln:
C1:  =a
C2:  =a
C3:  =a
C4:  =a
C5:  =a
C6:  =a
D1:  =b
D2:  =b
D3:  =b
D4:  =b
D5:  =b
D6:  =b
Namen in der Tabelle:
a:  =TEIL(IST!B1;1;(TEIL(IST!B1;1;1)<="9")+(TEIL(IST!B1;2;1)<="9")+(TEIL(IST!B1;3;1)<="9"))
b:  =TEIL(IST!IB1;LÄNGE(IST!B1)+1;LÄNGE(IST!IB1)-LÄNGE(IST!C1))
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html 

Bild

Betrifft: AW: Zellinhalte splitten
von: Heinz Ulm

Geschrieben am: 22.02.2005 23:01:26
Hallo Reinhard,
so gehts auch mit einer Ziffer + 1 Buchstaben
Tabelle1
 ABCD
13350069B9B
246465645BX45BX
31547122CZ2CZ
49325451A1A
51474451CZZ1CZZ
6454546100A100A
754445430AX30AX
Formeln der Tabelle
C1 : =WENN(LÄNGE(B1)=2;LINKS(B1;1);TEIL(B1;1;WENN(UND(CODE(TEIL(B1;3;1))<=57;CODE(TEIL(B1;3;1))>=48);3;WENN(UND(CODE(TEIL(B1;2;1))<=57;CODE(TEIL(B1;2;1))>=48);2;1))))*1
D1 : =RECHTS(B1;LÄNGE(B1)-LÄNGE(C1))
C2 : =WENN(LÄNGE(B2)=2;LINKS(B2;1);TEIL(B2;1;WENN(UND(CODE(TEIL(B2;3;1))<=57;CODE(TEIL(B2;3;1))>=48);3;WENN(UND(CODE(TEIL(B2;2;1))<=57;CODE(TEIL(B2;2;1))>=48);2;1))))*1
D2 : =RECHTS(B2;LÄNGE(B2)-LÄNGE(C2))
C3 : =WENN(LÄNGE(B3)=2;LINKS(B3;1);TEIL(B3;1;WENN(UND(CODE(TEIL(B3;3;1))<=57;CODE(TEIL(B3;3;1))>=48);3;WENN(UND(CODE(TEIL(B3;2;1))<=57;CODE(TEIL(B3;2;1))>=48);2;1))))*1
D3 : =RECHTS(B3;LÄNGE(B3)-LÄNGE(C3))
C4 : =WENN(LÄNGE(B4)=2;LINKS(B4;1);TEIL(B4;1;WENN(UND(CODE(TEIL(B4;3;1))<=57;CODE(TEIL(B4;3;1))>=48);3;WENN(UND(CODE(TEIL(B4;2;1))<=57;CODE(TEIL(B4;2;1))>=48);2;1))))*1
D4 : =RECHTS(B4;LÄNGE(B4)-LÄNGE(C4))
C5 : =WENN(LÄNGE(B5)=2;LINKS(B5;1);TEIL(B5;1;WENN(UND(CODE(TEIL(B5;3;1))<=57;CODE(TEIL(B5;3;1))>=48);3;WENN(UND(CODE(TEIL(B5;2;1))<=57;CODE(TEIL(B5;2;1))>=48);2;1))))*1
D5 : =RECHTS(B5;LÄNGE(B5)-LÄNGE(C5))
C6 : =WENN(LÄNGE(B6)=2;LINKS(B6;1);TEIL(B6;1;WENN(UND(CODE(TEIL(B6;3;1))<=57;CODE(TEIL(B6;3;1))>=48);3;WENN(UND(CODE(TEIL(B6;2;1))<=57;CODE(TEIL(B6;2;1))>=48);2;1))))*1
D6 : =RECHTS(B6;LÄNGE(B6)-LÄNGE(C6))
C7 : =WENN(LÄNGE(B7)=2;LINKS(B7;1);TEIL(B7;1;WENN(UND(CODE(TEIL(B7;3;1))<=57;CODE(TEIL(B7;3;1))>=48);3;WENN(UND(CODE(TEIL(B7;2;1))<=57;CODE(TEIL(B7;2;1))>=48);2;1))))*1
D7 : =RECHTS(B7;LÄNGE(B7)-LÄNGE(C7))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
Bild

Betrifft: AW: Zellinhalte splitten
von: Josef Ehrensberger
Geschrieben am: 22.02.2005 22:21:02
Hallo Dirk!
Guckst du hier: http://www.excelformeln.de/formeln.html?welcher=100

Gruß Sepp
P.S.: Rückmeldung nicht vergessen!
Bild

Betrifft: AW: Zellinhalte splitten
von: andre
Geschrieben am: 22.02.2005 22:31:48
Hallo Sepp,
ob bei Deinem Link was anderes steht als in dem, den ich vor gut einer 3/4 Stunde gepostet habe ? ;-)
Bild

Betrifft: Doppelt hält besser! m.T.
von: Josef Ehrensberger
Geschrieben am: 22.02.2005 22:37:42
Hallo Andre!
Hab dein Posting glatt überlesen;-))
Hab's erst bemerkt, als es schon zu spät war!

Gruß Sepp
Bild

Betrifft: AW: Doppelt hält besser! m.T.
von: andre
Geschrieben am: 22.02.2005 22:41:32
Hallo Sepp,
da gabs doch mal den Witz mit dem Psychiater -
Patient: Herr Arzt, ich werde immer übersehen, können Sie mir helfen ...
Psychiater: Der nächste bitte ...
Grüße, Andre ;-))
Bild

Betrifft: AW: Doppelt hält besser! m.T.
von: Josef Ehrensberger

Geschrieben am: 22.02.2005 22:46:11
Hallo Andre!
Ja und gegen Vergessen gibt's jetz auch ein neues Medikament!
Es heist, ääh, aah, sorry - hab's vergessen;-)

Gruß Sepp
Bild

Betrifft: AW: Zellinhalte splitten
von: Dirk

Geschrieben am: 23.02.2005 19:23:34

Nabend Zusammen,
erstmal vielen Dank an alle die hier gepostet haben!!!!
habe die Sachen alle mal probiert - die Lösung von Heinz Ulm
hat am besten funktioniert.
Aber kann mir jemand vielleicht sagen, warum bei Andre´s Vorschlag,
bei mir nur jeweils immer die ersten Zahlen ausgegeben werden??
habe die formel genau so eingegeben.
viele grüße
Dirk
 Bild
Excel-Beispiele zum Thema "Zellinhalte splitten"
Einlesen von Zellinhalten in Variablen Zellinhalte zeilenweise sortieren
Wiederherstellung des alten Zellinhaltes bei unerlaubten Werten Bereiche in Abhängigkeit eines Zellinhaltes drucken
Die tatsächliche Anzeige eines Zellinhaltes per VBA abrufen Zellinhalte in Verbindung mit Variablen in Textdatei schreiben
Zellinhalte aus Einzelblättern in Deckblatt übertragen Excel-Zellinhalte in Worddokument einlesen um per Email versenden
Zellinhalte über VBA verbinden Zellinhalte vor dem Verbinden der Zellen zusammenfassen