Doppelt auftretende Buchstabenpaare finden

Bild

Betrifft: Doppelt auftretende Buchstabenpaare finden von: TK
Geschrieben am: 22.02.2005 20:58:31

Hallo!

Ich möchte in Spalte A und B jeweils Namen hineinschreiben (Paarungen bei einem Turnier). Kann mir jemand sagen, mit welcher Formel ich 2 Suchkriterien auf einmal erledigen kann (evt. doppelte Paarungen herausfinden). Mit 'Zählenwenn' kann ich ja nur 1 Suchkriterium bearbeiten.

Danke für alle sachdienlichen Hinweise

TK

Bild


Betrifft: AW: Mehrfach auftretende Wertepaare finden von: Luc
Geschrieben am: 22.02.2005 21:11:52

Hallo TK,
dein Titel ist irreführend, dadurch meldet sich u.U. Keiner. Dein Problem ist hier ansonsten schon oft in ähnlicher Form behandelt worden. Ich schlage dir die Suchstichworte Matrixformel und Wenn (evtl noch Summenprodukt, Summewenn) vor. Da findest du bestimmt was Passendes.
Gruß Luc


Bild


Betrifft: AW: Doppelt auftretende Buchstabenpaare finden von: Heinz Ulm
Geschrieben am: 22.02.2005 21:42:35

Hallo TK,

vielleicht hilft dir das weiter:

Tabelle2
 ABCD
1MaierMüllerMaier/MüllerDoppelt
2HuberSchulzHuber/Schulz 
3MaierMüllerMaier/MüllerDoppelt
Formeln der Tabelle
C1 : =A1&"/"&B1
D1 : =WENN(ZÄHLENWENN(C:C;C1)>1;"Doppelt";"")
C2 : =A2&"/"&B2
D2 : =WENN(ZÄHLENWENN(C:C;C2)>1;"Doppelt";"")
C3 : =A3&"/"&B3
D3 : =WENN(ZÄHLENWENN(C:C;C3)>1;"Doppelt";"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



allerdings brauchst du eine Hilfsspalte.

Gruß Heinz


Bild


Betrifft: AW: Doppelt auftretende Buchstabenpaare finden von: Hübi
Geschrieben am: 22.02.2005 21:47:03

Hi TK,

mach was draus
Tabelle6
 ABCD
1Mannschaft1Mannschaft2sooder so
2ab  
3ac Paarung doppelt
4ae  
5    
6cd  
7ca Paarung doppelt
8dc  
9acDuplikatPaarung doppelt
Formeln der Tabelle
C2 : {=WENN(VERGLEICH(A2&B2;A$2:A$100&B$2:B$100;0)=ZEILE(A1);"";"Duplikat")}
D2 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A2)*($B$2:$B$20=B2)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B2)*($B$2:$B$20=A2)*($A$2:$A$20<>""))>1);"doppelt";"")
C3 : {=WENN(VERGLEICH(A3&B3;A$2:A$20&B$2:B$20;0)=ZEILE(A2);"";"Duplikat")}
D3 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A3)*($B$2:$B$20=B3)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B3)*($B$2:$B$20=A3)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")
C4 : {=WENN(VERGLEICH(A4&B4;A$2:A$20&B$2:B$20;0)=ZEILE(A3);"";"Duplikat")}
D4 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A4)*($B$2:$B$20=B4)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B4)*($B$2:$B$20=A4)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")
C5 : {=WENN(VERGLEICH(A5&B5;A$2:A$20&B$2:B$20;0)=ZEILE(A4);"";"Duplikat")}
D5 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A5)*($B$2:$B$20=B5)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B5)*($B$2:$B$20=A5)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")
C6 : {=WENN(VERGLEICH(A6&B6;A$2:A$20&B$2:B$20;0)=ZEILE(A5);"";"Duplikat")}
D6 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A6)*($B$2:$B$20=B6)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B6)*($B$2:$B$20=A6)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")
C7 : {=WENN(VERGLEICH(A7&B7;A$2:A$20&B$2:B$20;0)=ZEILE(A6);"";"Duplikat")}
D7 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A7)*($B$2:$B$20=B7)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B7)*($B$2:$B$20=A7)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")
C8 : {=WENN(VERGLEICH(A8&B8;A$2:A$20&B$2:B$20;0)=ZEILE(A7);"";"Duplikat")}
D8 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A8)*($B$2:$B$20=B8)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B8)*($B$2:$B$20=A8)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")
C9 : {=WENN(VERGLEICH(A9&B9;A$2:A$20&B$2:B$20;0)=ZEILE(A8);"";"Duplikat")}
D9 : =WENN(ODER(SUMMENPRODUKT(($A$2:$A$20=A9)*($B$2:$B$20=B9)*($A$2:$A$20<>""))>1;SUMMENPRODUKT(($A$2:$A$20=B9)*($B$2:$B$20=A9)*($A$2:$A$20<>""))>1);"Paarung doppelt";"")

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A2)*($B$2:$B$20=$B2)*($A$2:$A$20<>""))>1Abc
B21. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A2)*($B$2:$B$20=$B2)*($A$2:$A$20<>""))>1Abc
A31. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A3)*($B$2:$B$20=$B3)*($A$2:$A$20<>""))>1Abc
B31. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A3)*($B$2:$B$20=$B3)*($A$2:$A$20<>""))>1Abc
A41. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A4)*($B$2:$B$20=$B4)*($A$2:$A$20<>""))>1Abc
B41. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A4)*($B$2:$B$20=$B4)*($A$2:$A$20<>""))>1Abc
A51. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A5)*($B$2:$B$20=$B5)*($A$2:$A$20<>""))>1Abc
B51. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A5)*($B$2:$B$20=$B5)*($A$2:$A$20<>""))>1Abc
A61. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A6)*($B$2:$B$20=$B6)*($A$2:$A$20<>""))>1Abc
B61. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A6)*($B$2:$B$20=$B6)*($A$2:$A$20<>""))>1Abc
A71. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A7)*($B$2:$B$20=$B7)*($A$2:$A$20<>""))>1Abc
B71. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A7)*($B$2:$B$20=$B7)*($A$2:$A$20<>""))>1Abc
A81. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A8)*($B$2:$B$20=$B8)*($A$2:$A$20<>""))>1Abc
B81. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A8)*($B$2:$B$20=$B8)*($A$2:$A$20<>""))>1Abc
A91. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A9)*($B$2:$B$20=$B9)*($A$2:$A$20<>""))>1Abc
B91. / Formel ist =SUMMENPRODUKT(($A$2:$A$20=$A9)*($B$2:$B$20=$B9)*($A$2:$A$20<>""))>1Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: Doppelt auftretende Buchstabenpaare finden von: tk
Geschrieben am: 23.02.2005 19:20:53

Danke für Eure Tips! Es hat geklappt.

tk


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Doppelt auftretende Buchstabenpaare finden"