Mehrere Kriterien in SUMMEWENN

Bild

Betrifft: Mehrere Kriterien in SUMMEWENN
von: Thomas
Geschrieben am: 25.02.2005 16:26:41
Hi Leute,
ich suche eine Formel, die mir eine Spalte mit Zahlen summiert, wenn die jeweilige Zahl in einem bestimmten Bereich liegt.
Sobald ich jedoch in der Funktion "SUMMEWENN" zwei Kriterien eingebe, ist das Ergebnis 0!
SUMMEWENN(C:C;UND(">=200";"<400");D:D)~f~
Geb ich nur ein Kriterium ein, stimmt das Ergebnis.
~f~SUMMEWENN(C:C;">=200";D:D)
Das Problem muss doch in einer Formel zu lösen sein, ohne mehrere WENN-Funktionen zu verwenden.

Danke im Voraus

Thomas

Bild

Betrifft: Einfach 2 mal SUMMEWENN
von: Boris
Geschrieben am: 25.02.2005 16:30:20
Hi Thomas,
1 mal größer/gleich 200, 1 mal größer 400 - und letztere vom ersten subtrahieren.
Grüße Boris
Bild

Betrifft: AW: Einfach 2 mal SUMMEWENN
von: Thomas Frohn
Geschrieben am: 28.02.2005 14:03:19
Versteh ich leider nicht, Boris. Was soll die Subtraktion?
Thomas
Bild

Betrifft: AW: Mehrere Kriterien in SUMMEWENN
von: Berthold Grabr
Geschrieben am: 26.02.2005 12:33:00
Hallo Thomas,
nimm folgende Funktion:

Function Summe2Wenn(Bed1 As Range, Bed2 As Range, Suche1, Suche2, Werte As Range)
'summiert Werte in Abhängigkeit von 2 Bedingungen mittels Durchsuchung von 2 Spalten
Dim Anzahl As Integer, i As Integer
Dim Summe As Single
    Summe = 0
    Anzahl = Bed1.Cells.Count
    For i = 1 To Anzahl
        If Bed1(i).Value = Suche1 And Bed2(i).Value = Suche2 Then
            Summe = Summe + Werte(i).Value
        End If
    Next i
    Summe2Wenn = Summe
End Function

Gruß
Berthold
Bild

Betrifft: AW: Mehrere Kriterien in SUMMEWENN
von: Thomas
Geschrieben am: 26.02.2005 13:52:46
Danke für die Antwort Berthold, aber geht das nicht auch ohne VBA? Das muss doch irgendwie zu lösen sein.
Thomas
Bild

Betrifft: AW: Mehrere Kriterien in SUMMEWENN
von: Markus
Geschrieben am: 26.02.2005 14:35:07
Hallo Thomas,
kannst du mal eine Beispieldatei laden?
Gruß
Markus
Bild

Betrifft: AW: Mehrere Kriterien in SUMMEWENN
von: Berthold Grabe
Geschrieben am: 26.02.2005 15:47:14
Hallo Thomas,

diese Antwort stammt von Boris:
Diese Lösung gehört doch fast schon zu Standard:
=SUMMENPRODUKT((A1:A100="x")*(B1:B100="y")*C1:C100)
Summiert Spalte C, wenn Spalte A="x" und B="y".
Und dürfte - auch wenn jede Zeile innerhalb des Arrays einzeln berechnet wird - um einiges flotter sein als eine For-Next-Schleife.
Gruß
Berthold
Bild

Betrifft: AW: Mehrere Kriterien in SUMMEWENN
von: Boris
Geschrieben am: 26.02.2005 18:42:33
Hi Thomas,
...aber geht das nicht auch ohne VBA? Das muss doch irgendwie zu lösen sein...
Muss man das jetzt verstehen? Schaust du dir auch alle Beiträge an?
Grüße Boris
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Mehrere Kriterien in SUMMEWENN"