Erster Wert / Letzter Wert / Textfarbe

Bild

Betrifft: Erster Wert / Letzter Wert / Textfarbe
von: OLLI
Geschrieben am: 27.02.2005 13:46:51
Hallo !
Ich habe in Excel eine Liste mit Werten (Zahlen).
Das hat was mit Tauchen zu tun.
Die Werte sind beispielsweise in A1 bis A100.
Die Werte können vorhanden sein, aber manche auch nicht.
Damit will ich sagen, dass die Werte auch bei A20 beginnen können und das in der Liste auch Lücken sein können (manche Werte nicht gefüllt).
Nun will ich folgendes machen:
Ich will den ERSTEN Wert in der Liste herausfinden (der kann bei A1 aber auch bei A20 sein).
Ich will den LETZTEN Wert in der Liste herausfinden (der kann bei A10 aber auch bei A100 sein).
Jetzt kann ich mit diesen Werten Rechnen.
Dazu will ich in B1 beispielsweise eine Differenz des ersten und des letzten Wertes rechnen. Momentan passe ich die Formel (= Beginnzelle - EndeZelle) einfach manuell an, um das Ergebis zu bekommen.
Dann will ich noch prüfen/machen:
- ist die Differenz größer 0 dann schreibe den Text "Planwert überschritten" in ROTER Schrift
- ist die Differenz gleich 0 dann schreibe den Text "Planwert eingehalten" in BLAUER Schrift
- ist die Differenz kleiner 0 dann schreibe den Text "Planwert unterschritten" in GRÜNER Schrift
Wie kann ich also Texte in einer Zelle in einer Bestimmten Farbe darstellen ?
Das mit "Wenn x dann y sonst Z" funktioniert, aber noch nicht mit den Textfarben.
Und wie bekomme ich von einer Liste den Ersten und den Letzten Wert raus, wenn die Liste von A1 bis 100 geht, aber der erste Wert irgendwo sein kann und genauso der letzte Wert. Und wenn zwischendrin einige Zellen leer sein können.
Danke !

Gruß

OLLI

Bild

Betrifft: AW: Erster Wert / Letzter Wert / Textfarbe
von: Josef Ehrensberger
Geschrieben am: 27.02.2005 13:59:35
Hallo olli!
Meinst du so?
 
 ABCD
1    
2 Erster Wert:11 
3 Letzter Wert:9 
4 Planwert:Plantwert überschrittenSchriftfarbe: "blau"
5    
6    
7    
811   
9    
107   
11    
1215   
13    
144   
15    
1615   
17    
1812   
194   
208   
219   
2211   
23    
24    
25    
269   
27    
Formeln der Tabelle
C2 : {=INDEX(A1:A100;VERGLEICH(WAHR;ISTZAHL(A1:A100);0))}
C3 : =INDEX(A1:A100;VERWEIS(2;1/ISTZAHL(A1:A100);ZEILE(A:A)))
C4 : ="Plantwert " &WENN(C2-C3<0;"unterschritten";WENN(C2-C3=0;"eingehalten";"überschritten"))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
C41. / Formel ist =C2-C3>0Abc
C42. / Formel ist =C2-C3<0Abc
 


Gruß Sepp
Bild

Betrifft: AW: Erster Wert / Letzter Wert / Textfarbe
von: OLLI
Geschrieben am: 27.02.2005 14:31:01
Danke, ja das hilft mir !
Problem gelöst.
Ihr hättet nur noch schreiben müssen, dass ich im Menü "Format" unter dem Menüpunkt "Bedingte Formatierung" meine Formatierungen machen kann.
Formalen klappen super und die Formatierungen jetzt auch !
DANKE !
Bild

Betrifft: AW: Erster Wert / Letzter Wert / Textfarbe
von: HermannZ
Geschrieben am: 27.02.2005 14:04:37
Hallo OLLI,
ein anderes Beispiel;
Summe
 ABC
2084   
2085Von Wert in erster Zelle Spalte A den letzten Wert der Spalte A subtrahieren  
2086   
20872312Planwert überschritten
208834  
208945  
209056  
20912  
209223  
209334  
209445  
209556  
209634  
209745  
209856  
20992  
210023  
210111  
Formeln der Tabelle
B2087 : {=A2087-INDEX(A:A;MAX(ISTZAHL(A2087:A2101)*ZEILE(A2087:A2101)))}
C2087 : =WENN(B2087>0;"Planwert überschritten";WENN(B2087=0;"Planwert eingehalten";"Planwert überschritten"))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hermann
Bild

Betrifft: AW:Formatierung vergessen Sorry.....
von: HermannZ
Geschrieben am: 27.02.2005 14:13:42
richtiges Beispiel;
Summe
 ABC
2085Von Wert in erster Zelle Spalte A den letzten Wert der Spalte A subtrahieren  
2086   
2087230Planwert eingehalten
208834  
208945  
209056  
20912  
209223  
209334  
209445  
209556  
209634  
209745  
209856  
20992  
210023  
210123  
2102   
Formeln der Tabelle
B2087 : {=A2087-INDEX(A:A;MAX(ISTZAHL(A2087:A2101)*ZEILE(A2087:A2101)))}
C2087 : =WENN(B2087>0;"Planwert überschritten";WENN(B2087=0;"Planwert eingehalten";"Planwert überschritten"))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
C20871. / Formel ist =B2087>0Abc
C20872. / Formel ist =B2087=0Abc
C20873. / Formel ist =B2087<0Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Erster Wert / Letzter Wert / Textfarbe"