Herbers Excel-Forum - das Archiv

Minimum

Bild

Betrifft: Minimum
von: Lukas

Geschrieben am: 28.02.2005 09:14:32
Moin
Ich habe von Zelle A1-A20 diverse Zahlen
Mit der Formel die ich suche möchte ich nun die kleinste Zahl aus dem Bereich A1:A20 falls es eine kleinste Zahl gibt, d.h. sobald 2 gleiche Zahlen die 2. kleinsten sind möchte ich den Wert 0.
Kann mir jemand helfen?
Gruss und schonmal vielen Dank
Lukas
Bild

Betrifft: AW: Minimum
von: Matthias G
Geschrieben am: 28.02.2005 09:17:39
Hallo Lukas,
=NICHT(KKLEINSTE(A1:A20;1)=KKLEINSTE(A1:A20;2))*KKLEINSTE(A1:A20;1)
Gruß Matthias
Bild

Betrifft: Funktioniert
von: Lukas
Geschrieben am: 28.02.2005 09:23:55
Danke vielmals Matthias!!!
Superschnelle Antwort! Danke!
nun, kannst du mir noch kurz in ein paar Worten erklären was diese Formel nun rechnet? Möchte es auch verstehen. Was bedeutet die 1 und 2 ???
Gruss
Lukas
Bild

Betrifft: AW: Funktioniert
von: Herbert
Geschrieben am: 28.02.2005 09:27:57
bei nur einem Wert im Bereich entsteht ein Fehler.
Bild

Betrifft: AW: Funktioniert
von: Matthias G

Geschrieben am: 28.02.2005 09:39:26
Hallo Herbert,
danke für den Hionweis.
Ich weiß nicht, ob er bei Lukas auftreten kann, aber man kann ihn ja abfangen:
=WENN(ISTFEHLER(KKLEINSTE(A1:A20;2));KKLEINSTE(A1:A20;1);NICHT(KKLEINSTE(A1:A20;1)=KKLEINSTE(A1:A20;2))*KKLEINSTE(A1:A20;1))
Gruß Matthias
P.S. Und jetzt sag nicht, wenn der Bereich leer ist, kommt ein Fehler ;-)
Bild

Betrifft: AW: Funktioniert
von: Matthias G

Geschrieben am: 28.02.2005 09:29:19
Hallo Lukas,
NICHT(KKLEINSTE(A1:A20;1)=KKLEINSTE(A1:A20;2))
ist FALSE, wenn die erstkleinste gleich der zweitkleinsten Zahl ist
ein Wert mit FALSE multipliziert ergibt 0
ein Wert mit TRUE multipliziert ergibt einfach den Wert
Gruß Matthias
Bild

Betrifft: AW: Minimum
von: UweD

Geschrieben am: 28.02.2005 09:24:46
Hallo
meinst du das?
 
 A
11
21
3 
42
52
6 
7 
8 
9 
10 
11 
12 
13 
14 
15 
16 
17 
18 
19 
20 
21 
22bedingtes Min
230
Formeln der Tabelle
A23 : =WENN(ISTFEHLER(WENN(MIN($A$1:$A$20)=KKLEINSTE($A$1:$A$20;2);0;MIN(A1:A20)));"";WENN(MIN($A$1:$A$20)=KKLEINSTE($A$1:$A$20;2);0;MIN(A1:A20)))
 

Gruß Uwe
Bild

Betrifft: Welche nun? ;)
von: Lukas
Geschrieben am: 28.02.2005 09:47:26

Danke vielmals für euer Engagement!
Aber kommen jetzt die 2 Formeln von Dir Matthias und von Dir Uwe auf das gleiche Resultat?
Für mich sind die Formeln noch ein bisschen undurchsichtig, deshalb frage ich.
Gruss
Lukas
Bild

Betrifft: AW: Welche nun? ;)
von: Matthias G
Geschrieben am: 28.02.2005 09:50:08
Hallo Lukas,
probier's halt aus, es gibt immer mehr als 1 Lösung ;-)
Gruß Matthias
 Bild
Excel-Beispiele zum Thema "Minimum"
Datensätze mit Minimumwert übernehmen