Herbers Excel-Forum - das Archiv

Doppelte Zahlen ausfindig machen

Bild

Betrifft: Doppelte Zahlen ausfindig machen
von: Michael

Geschrieben am: 01.03.2005 11:50:23
Hallo Excel-User,
hab ein kleines Excel-Problem (Excel XP)
Habe drei Tabellenblätter mit reinen Zahlenreihen: Liste1, Liste2, Liste3.
Diese kopiere ich immer zusammen auf ein Blatt in drei Spalten.
Nun möchte ich filtern:
welche Nummern sowohl in Liste1, 2 und 3 bzw. Spalte1, 2 und 3 sind, d.h. Kennzeichnung der Zahlen, die mehr als einmal vorkommen.
Dazu wäre es schön, folgendes zu haben:
Gibt es einen Befehl oder ein Makro, das mit die Zahlen kennzeichnet die doppelt sind.
Gut wäre es, wenn z.B. in einer neuen Spalte dann einfach ein x steht oder das irgendwie anders gefiltert werden kann.
Freu mich auf eure Tipps und Hilfe
Viele Grüße
Michael
Bild

Betrifft: AW: Doppelte Zahlen ausfindig machen
von: Hajo_Zi

Geschrieben am: 01.03.2005 11:54:23
Hallo Michael,
das geht ohne Makro mit bedingter Formatierung.
So in der Art.
Doppelte Einträge
Annahme: Deine Werte stehen in A1 bis Axx
A1 anwählen, Format, Bedingte Formatierung (bei bedingter Formatierung soll es eine Grenze von 2050 Zeilen geben, mal selber Testen)
"Formel ist" auswählen NICHT "Zellwert ist"
Bei der Formel eingeben =ZÄHLENWENN(A$1:A1;A1)>1
Bei Format dann z.B. Musterfarbe rot auswählen mit OK beenden.
Die Formatierung auf Die Zellen A2 bis Axx kopieren. Fertig
Dann werden Doppelt farblich gekennzeichnet

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


 Bild
Excel-Beispiele zum Thema "Doppelte Zahlen ausfindig machen"
Doppelte Einträge finden und löschen Doppelte Datensätze löschen
Doppelte Zelleinträge listen Doppelte Datensätze und Leerzeilen löschen
Doppelte Datensätze farblich markieren und auflisten Doppelte Eingabe von Werten verhinden
In mehrere Spalten doppelte Inhalte entfernen Doppelte Einträge in UserForm-ListBox löschen
Auf Doppelte prüfen, bevor Tabelleneintrag Vorkommen von Zahlenreihen in Spalten