Herbers Excel-Forum - das Archiv

Filter?

Bild

Betrifft: Filter?
von: Roman

Geschrieben am: 02.03.2005 10:48:23
Hallo,
habe in Spalte A Lieferantennamen, in B1 steht ein Legierungsname: Nickel.
Nun möchte ich aus einer ("roh") Tabelle, die ein wenig weiter steht in M-Z folgendes filtern.
Ich möchte gerne die Summierung aller Tonnagen von Nickel haben, die der Lieferant in A2 geliefert an.
in der "Rohen" TAbelle kommt der Lieferantenname öffter vor und muß somit geschaut werden es Nickel ist oder was anders. Denn die Lieferanten Liefern mehrere Legierungen.
Es soll also nach zwei Faktoren gefiltern werden einmal nach dem Namen des Leifernaten und das andere ist dann die Legierung und wenn diese beiden übereinstimmen, dann sollte die Tonnage addiert werden.
Zur Zeit sortiere ich nach den Lieferanten und addiere die komplette Tonnage und nun möchte ich die Tonnage nach Legierungen auf teilen.

Kann mir da einer helfen?
Gruß
Roman
Bild

Betrifft: AW: Filter?
von: Harald E
Geschrieben am: 02.03.2005 11:11:55
Hallo Roman,
eine Möglichkeit wäre,
=SUMMENPRODUKT((A1:A1000="Lieferant")*(B1:B1000="Legierung")*(C1:C1000))
Wobei in Spalte C die Tonnagen stehen sollte.
Gruß
Harald
Bild

Betrifft: AW: Filter?
von: Roman
Geschrieben am: 02.03.2005 11:25:06
Hallo,
super ich habe es damit hinbekommen. vielen dank.
ging echt flott.
habe zwar einwenig die Formel bearbeitet, aber zu 99 Prozent war alles ok.
Gruß
Roman
Bild

Betrifft: Danke für die Rückmeldung :-) o.T.
von: Harald E
Geschrieben am: 02.03.2005 11:41:50
 Bild
Excel-Beispiele zum Thema "Filter?"
Dateinamen filtern Summe gefilterter Zeilen
Filtern einer Zahl aus einer Zeichenfolge Gefilterte Daten in eine ListBox einlesen
Gefilterte Daten ohne Zwischenablage übertragen Gefilterte Daten in neues Tabellenblatt übertragen
Autofilter auch mit Ziffern von Zahlen Daten eines bestimmten Jahres filtern
Zellenwert als Autofilter-Kriterienwert