Formeln verketten

Bild

Betrifft: Formeln verketten von: Luki
Geschrieben am: 12.03.2005 11:22:06

Ich hab eine Formel "=ZELLE("Inhalt";B4)" die ja prächtig funktioniert, aber:
wie füge ich statt dem 4 die nächste Formel ein?
"=ZELLE("Inhalt";B(VERGLEICH("wort";A1:A7;1)))" funktioniert nicht.
Hiiilfe!
Ligrü Luki

Bild


Betrifft: AW: Formeln verketten von: c0bRa
Geschrieben am: 12.03.2005 11:32:02

hallo...

schau dir mal die funktion indirekt() an... ich denk mal das ist das, was du suchst... :)


Rückmeldungen gehören auch zu einem Forum
c0bRa


Bild


Betrifft: AW: Formeln verketten von: Hajo_Zi
Geschrieben am: 12.03.2005 11:36:49

Hallo

warum muß es die Funktion Zelle sein?
Es wird doch nur der Inhalt einer bestimmten Zelle angezeigt? Oder Sehe ich da was Falsch?


Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.




Bild


Betrifft: AW: Formeln verketten von: Luki
Geschrieben am: 12.03.2005 11:49:27

Ich sitze noch immer am altbekannten Problem ;-(

Kurt; 4
Spende Rolf; 7

Ich möchte aus der Zelle "Spende Rolf" einfach nur Rolf erkennen und 7 ausgeben *heul*
SVERWEIS findet nur "Rolf" - "Spende Rolf" nicht.

Mit ZELLE("Inhalt";??) und einer netten Formel (z.B. VERGLEICH) statt ?? erhoffen ich mir endlich eine Lösung


Bild


Betrifft: AW: Formeln verketten von: Hajo_Zi
Geschrieben am: 12.03.2005 11:54:49

Hallo Luki,

lade doch mal eine Datei hoch un schreibe rein was Du willst. Ich vermute mal die Firmelfreaks finden da schon eine Lösung. Sie müßten aber erst Dein Beispiel nachbauen und Du weist ja wie Leute so sind.

Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: Formeln verketten von: Luki
Geschrieben am: 12.03.2005 12:12:19

hier (hoffentlich) mein problem als xls
https://www.herber.de/bbs/user/19556.xls


Bild


Betrifft: AW: Formeln verketten von: Hajo_Zi
Geschrieben am: 12.03.2005 12:17:10

Hallo Luki,

Tabelle1
 ABCDE
1Kurt10 Kurt10
2Michael12 Michael12
3Spende Simon15 Simon15
4Mitgliedsbeitrag Karl20 Karl20
Formeln der Tabelle
E1 : =SUMMEWENN(A1:A4;"*" & D1 &"*";B1:B5)
E2 : =SUMMEWENN(A2:A5;"*" & D2 &"*";B2:B6)
E3 : =SUMMEWENN(A3:A6;"*" & D3 &"*";B3:B7)
E4 : =SUMMEWENN(A4:A7;"*" & D4 &"*";B4:B8)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: Formeln verketten von: Luki
Geschrieben am: 12.03.2005 12:28:42

Cool, Danke!!
Die Formel muß ich erst verdauen, aber es lebt!

;-) Luki


Bild


Betrifft: AW: Formeln verketten von: Luki
Geschrieben am: 12.03.2005 13:54:42

Eine Frage hätte ich noch:
Wie krieg ich da noch eine Wenn-Bedingung rein? Wenn in C Zahlen stehen, und nur bei einem 5er möchte ich den Wert zählen? Wie geht das?


Bild


Betrifft: AW: Formeln verketten von: c0bRa
Geschrieben am: 12.03.2005 14:14:17

gibt 2 möglichkeiten...

wenn ohne c=5 ne null drinstehen soll, dann
=SUMMEWENN($A$1:$A$4;"*"&D1&"*";$B$1:$B$4)*($C$1:$C$4=5)
wenn nix drinstehen soll, dann:
=WENN($C$1:$C$4=5;SUMMEWENN($A$1:$A$4;"*"&D1&"*";$B$1:$B$4);"")
sonst ist es dir überlassen

ich hab die zellbezüge mal absolut gemacht, weil sonst beim runterkopieren sich dein bereich verschiebt...
https://www.herber.de/bbs/user/19569.xls


Rückmeldung nicht vergessen...
c0bRa


Bild


Betrifft: AW: Formeln verketten von: Luki
Geschrieben am: 14.03.2005 13:40:19

Mir schreibt er bei beiden Formeln #WERT!
und die angehängte Formel übernimmt den wert, wenn nichts drinnen steht, nicht wenn 5 drinnen steht.

Und je mehr ich ausprobiere, desto mehr bekomm ich Kopfschmerzen, weil nichts funktioniert.
Kann jemand vielleicht noch eine Formel aus dem Ärmel schütteln, bzw. mir erklären, warum er mir #WERT! schreibt?

Verzweifelte Grüße


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formeln verketten"