Einzelne Bereiche auszählen

Bild

Betrifft: Einzelne Bereiche auszählen
von: Pascal
Geschrieben am: 16.03.2005 15:01:46
Liebe Excel-Speziallisten,
Meine Aufgabe:
Habe in Spalte A fortlaufenden Datumsangaben, in B die dazugehörigen Werte. Ich will nun, dass mir Excel die Tage des längsten zusammenhängenden Bereich zählt, in welchem die Daten z.b. kleiner 30.
Beispiel:
vom 01.03.1999 bis zum 20.03.1999 sind die Werte kleiner als 30, also erhalte ich als Resultat 30 Tage!
Falls hier als Beispiel am 15.03.1999 der Wert 31 ist, da soll das Resulat 15 Tage sein.
Ich hoffe Jemand versteht mich und kann mit weiterhelfen. Ich bin dankbar um jeden Hinweis, z.b. welche Formel ich benützen muss.
Habe es mit zählenwenn probiert, die Formel zählt mit aber alle Tage im Ganzen Jahr, wo der Wert kleiner 30 ist...
Danke, mfg Pascal

Bild

Betrifft: Thread von Gestern - Laufvariable
von: Luc
Geschrieben am: 16.03.2005 15:44:57
Hallo Pascal,
was ist eigentlich mit deinem Thread von Gestern? Da kam keine Rückmeldung deinerseits mehr! Das ist nicht nur eine Frage der Höflichkeit, sondern auch in deinem eigenen Interesse. Mitunter kommt da ja immer noch was.
mfG Luc ;-|
Bild

Betrifft: AW: Thread von Gestern - Laufvariable
von: Pascal
Geschrieben am: 16.03.2005 15:50:40
hallo luc,
tatsächlich war ich gestern im forum, habe auf zwei user "luigi" und "andreas" geantwortet. mit dem user "pascal" welcher etwas von der laufvariable wollte, habe ich nichts zu tun.
gruss pascal
p.s.: ich antworte immer auf meine fragen.
Bild

Betrifft: OK - Danke, hätt ja sein können... - owT
von: Luc :-?
Geschrieben am: 16.03.2005 16:58:15

Bild

Betrifft: AW: Einzelne Bereiche auszählen
von: Pascal alias der Andere
Geschrieben am: 16.03.2005 16:32:35
Hallo,
Ich konnte mein Problem selber lösen! Hier die Lösung:
Man schreibe in Spalte C, Zelle C2 die Formel
=WENN($E$2<=B2;1;"")~f~
wobei E2 30 ist, und B2 der erste Wert.
In Spalte D, Zelle D2 schreibt man nun:
~f~=WENN(C2=1;C2+D1;0)~f~
Die beiden Formeln zieht man den ganzen Bereich herunter...
Und dann sucht man mit
~f~=MAX(D:D) das Maximum! Fertig.
Gruss Pascal, der Andere...
Bild

Betrifft: beendet --- owT
von: Luc :-?
Geschrieben am: 17.03.2005 21:40:09

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Einzelne Bereiche auszählen"