Aus Matrix auslesen

Bild

Betrifft: Aus Matrix auslesen
von: markus
Geschrieben am: 16.03.2005 15:17:45
Hallo,
ich habe eine Datei in der ich die Anfangs und End Zeiten einzelner Mitarbeiter habe.

Gruppe
 BCDEFGHIJKL
2NameAnfang-MontagEnde-MontagAnfang-DienstagEnde-DienstagAnfang-MittwochEnde-MittwochAnfang-DonnerstagEnde-DonnerstagAnfang-FreitagEnde-Freitag
3Ines G.08:0013:1508:0013:1508:0012:3008:5012:3008:0012:30
4Laura R.08:0013:1508:0013:15neinnein08:0013:1508:0012:30
5Isabelle T.neinnein08:0013:1508:0013:1508:0013:1508:5011:30
6XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
7Anika V.08:1513:00neinnein08:3013:00neinnein08:1513:00
8Lena P.08:1513:00neinnein08:1512:0008:1513:0008:1512:00
9Joel D.08:0012:3008:0013:1508:5012:3008:0013:1508:0012:30
10Denise D.08:0012:3008:0012:3008:0011:3008:0013:1508:0011:30
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
nun möchte ich aber daraus eine Übersicht auf Tagesbasis haben, also wann am Dienstag fängt wer an. So wie hier
Tabelle1
 ABC
2Dienstag-Anfang  
3   
407:4508:0008:15
5Joel D.Ines G. 
6XXXXXXXXX
7 Isabelle T. 
8 Laura K. 
9 Anika V. 
10 Lena P. 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Und das ist nur ein Auszug, ich habe ca. 150 Namen und möchte je Tag Anfangs und Endzeiten als Überblick bekommen. Wie mache ich dies am Besten? Danke im Voraus Markus
Bild

Betrifft: AW: Aus Matrix auslesen
von: Heinz Ulm
Geschrieben am: 19.03.2005 01:23:32
Hallo Marcus,
mal ein Gedankenanstoß, so könnte es mit Hilfsspalten gehen:
Tabelle1
 BCDEFGHI
2NameAnfang-MontagEnde-Montag07:4508:0008:15Anfang-DienstagEnde-Dienstag
3        
4Ines G.08:0013:15  108:1513:15
5Laura R.08:0013:15 1008:0013:15
6Isabelle T.neinnein 2008:0013:15
7XXXXXXXXX  208:15XXX
8Anika V.08:1513:00   neinnein
9Lena P.08:1513:00   neinnein
10Joel D.08:0012:3013007:4513:15
11Denise D.08:0012:30 4008:0012:30
12        
13        
14 Dienstag-Anfang      
15        
16 07:4508:0008:15    
171Joel D.Laura R.Ines G.    
182 Isabelle T.XXX    
193 Joel D.     
204 Denise D.     
215       
226       
Formeln der Tabelle
E4 : =WENN(H4="nein";"";WENN(H4<$F$2;MAX($E$3:E3)+1;""))
G4 : =WENN(H4="nein";"";WENN(H4>$F$2;MAX($G$3:G3)+1;0))
E5 : =WENN(H5="nein";"";WENN(H5<$F$2;MAX($E$3:E4)+1;""))
F5 : =WENN(H5="nein";"";WENN(H5<=$F$2;MAX($F$3:F4)+1;""))
G5 : =WENN(H5="nein";"";WENN(H5>$F$2;MAX($G$3:G4)+1;0))
E6 : =WENN(H6="nein";"";WENN(H6<$F$2;MAX($E$3:E5)+1;""))
F6 : =WENN(H6="nein";"";WENN(H6<=$F$2;MAX($F$3:F5)+1;""))
G6 : =WENN(H6="nein";"";WENN(H6>$F$2;MAX($G$3:G5)+1;0))
E7 : =WENN(H7="nein";"";WENN(H7<$F$2;MAX($E$3:E6)+1;""))
F7 : =WENN(H7="nein";"";WENN(H7<=$F$2;MAX($F$3:F6)+1;""))
G7 : =WENN(H7="nein";"";WENN(H7>$F$2;MAX($G$3:G6)+1;0))
E8 : =WENN(H8="nein";"";WENN(H8<$F$2;MAX($E$3:E7)+1;""))
F8 : =WENN(H8="nein";"";WENN(H8<=$F$2;MAX($F$3:F7)+1;""))
G8 : =WENN(H8="nein";"";WENN(H8>$F$2;MAX($G$3:G7)+1;0))
E9 : =WENN(H9="nein";"";WENN(H9<$F$2;MAX($E$3:E8)+1;""))
F9 : =WENN(H9="nein";"";WENN(H9<=$F$2;MAX($F$3:F8)+1;""))
G9 : =WENN(H9="nein";"";WENN(H9>$F$2;MAX($G$3:G8)+1;0))
E10 : =WENN(H10="nein";"";WENN(H10<$F$2;MAX($E$3:E9)+1;""))
F10 : =WENN(H10="nein";"";WENN(H10<=$F$2;MAX($F$3:F9)+1;""))
G10 : =WENN(H10="nein";"";WENN(H10>$F$2;MAX($G$3:G9)+1;0))
E11 : =WENN(H11="nein";"";WENN(H11<$F$2;MAX($E$3:E10)+1;""))
F11 : =WENN(H11="nein";"";WENN(H11<=$F$2;MAX($F$3:F10)+1;""))
G11 : =WENN(H11="nein";"";WENN(H11>$F$2;MAX($G$3:G10)+1;0))
C17 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B17;$E$3:$E$11;0)+2));"";INDIREKT("B"&VERGLEICH(B17;$E$3:$E$11;0)+2))
D17 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B17;$F$3:$F$11;0)+2));"";INDIREKT("B"&VERGLEICH(B17;$F$3:$F$11;0)+2))
E17 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B17;$G$3:$G$11;0)+2));"";INDIREKT("B"&VERGLEICH(B17;$G$3:$G$11;0)+2))
C18 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B18;$E$3:$E$11;0)+2));"";INDIREKT("B"&VERGLEICH(B18;$E$3:$E$11;0)+2))
D18 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B18;$F$3:$F$11;0)+2));"";INDIREKT("B"&VERGLEICH(B18;$F$3:$F$11;0)+2))
E18 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B18;$G$3:$G$11;0)+2));"";INDIREKT("B"&VERGLEICH(B18;$G$3:$G$11;0)+2))
C19 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B19;$E$3:$E$11;0)+2));"";INDIREKT("B"&VERGLEICH(B19;$E$3:$E$11;0)+2))
D19 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B19;$F$3:$F$11;0)+2));"";INDIREKT("B"&VERGLEICH(B19;$F$3:$F$11;0)+2))
E19 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B19;$G$3:$G$11;0)+2));"";INDIREKT("B"&VERGLEICH(B19;$G$3:$G$11;0)+2))
C20 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B20;$E$3:$E$11;0)+2));"";INDIREKT("B"&VERGLEICH(B20;$E$3:$E$11;0)+2))
D20 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B20;$F$3:$F$11;0)+2));"";INDIREKT("B"&VERGLEICH(B20;$F$3:$F$11;0)+2))
E20 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B20;$G$3:$G$11;0)+2));"";INDIREKT("B"&VERGLEICH(B20;$G$3:$G$11;0)+2))
C21 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B21;$E$3:$E$11;0)+2));"";INDIREKT("B"&VERGLEICH(B21;$E$3:$E$11;0)+2))
D21 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B21;$F$3:$F$11;0)+2));"";INDIREKT("B"&VERGLEICH(B21;$F$3:$F$11;0)+2))
E21 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B21;$G$3:$G$11;0)+2));"";INDIREKT("B"&VERGLEICH(B21;$G$3:$G$11;0)+2))
C22 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B22;$E$3:$E$11;0)+2));"";INDIREKT("B"&VERGLEICH(B22;$E$3:$E$11;0)+2))
D22 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B22;$F$3:$F$11;0)+2));"";INDIREKT("B"&VERGLEICH(B22;$F$3:$F$11;0)+2))
E22 : =WENN(ISTNV(INDIREKT("B"&VERGLEICH(B22;$G$3:$G$11;0)+2));"";INDIREKT("B"&VERGLEICH(B22;$G$3:$G$11;0)+2))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Aus Matrix auslesen"