Arbeitszeitzuschläge berechnen

Bild

Betrifft: Arbeitszeitzuschläge berechnen
von: loe
Geschrieben am: 17.03.2005 15:13:53
Hallo
könnte mir mal eben jemand auf die Sprünge helfen.
Ich möchte in der folgenden Tabelle die Zuschläge für Mehrarbeit berechnen.
Die Zuschläge beziehen Sie jeweils auf olgende Zeiten:
00:00 Uhr bis 06:00 Uhr
20:00 Uhr bis 24:00 Uhr
Es tut mir leid, dass ich im MOment keine Tabelle zum Server bekomme !
Spalte A Arbeitsbeginn
Spalte B Arbeitsende
Spalte F Zuschläge
Angenommen der Arbeiter fängt jetzt um 05:00 Uhr an, dann müßte in ZUschläge eine 1,0 stehen (06:00 - 05:00)
Angenommen der Arbeiter beendet seine Arbeit um 23:15 dann müßte in ZUschläge eine 1,25 stehen.
Angenommen der Arbeiter beginnt um 05:00 UHr und beendet um 23:30 UHr, dann müsste in ZUschläge eine 4,5 stehen (06:00 Uhr - 05:00 Uhr; 23:30-20:00 Uhr)
Vielen Dank im voraus

Gruß
loe

Bild

Betrifft: AW: Arbeitszeitzuschläge berechnen
von: Frank Domke
Geschrieben am: 17.03.2005 15:24:20

=WENN(A2<ZEIT(6;0;0);ZEIT(6;0;0)-A2;0)+WENN(B2>ZEIT(20;0;0);B2-ZEIT(20;0;0);0)
Viel Erfolg
Frank.
Bild

Betrifft: AW: Dank+Änderung
von: loe
Geschrieben am: 17.03.2005 15:34:46
Hallo Frank,
vielen DAnk für die Antworten. Mußte die Formel noch kurz ändern, damit sie im dezimal läuft, aber hat mich sehr voran gebracht. Nochmals besten Dank.
=WENN(A2ZEIT(20;0;0);B2-ZEIT(20;0;0)*24;0)
Gruß
loe
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeitzuschläge berechnen"