Wenn Formel verlängern

Bild

Betrifft: Wenn Formel verlängern
von: Dallwitz
Geschrieben am: 31.03.2005 16:21:50
Gibt es die Mgl. eine wenn Formel zu verlängern? oder gibt es eine andere Mgl. folgendes auszudrücken:
Zelle A1 = steht Monat in Form von Zahl (1-12) geschrieben
Zelle A2= soll bei einer 1 Jan stehen, bei einer 2 Jan-Feb, bei einer 3 Jan-Mrz etc.
Ich würde mich über Lösungsvorschläge sehr freuen, vielen Dank im voraus

Bild

Betrifft: AW: Wenn Formel verlängern
von: Thomas
Geschrieben am: 31.03.2005 16:25:16
WENN(A1=1;A2="Jan";WENN(A1=2;A2="Feb";WENN...)))
Grüße
Thomas
Bild

Betrifft: ...und bei Juli is schluss ;)
von: c0bRa
Geschrieben am: 31.03.2005 16:28:10
da funktionen max 7x ineinander verschachtelt werden können...
c0bRa
Bild

Betrifft: AW: Wenn Formel verlängern
von: c0bRa
Geschrieben am: 31.03.2005 16:26:33
hallo...
probier mal:
=WENN(A1=1;TEXT(A1;"MMM");TEXT(1;"MMM")&"-"&TEXT(DATUM(JAHR(HEUTE());A1;1);"MMM"))
weiß aber a1 dann noch die gültigkeit von 1 12 zu, da sonst humbug rauskommt, wenn da 13 drinsteht ;)

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: ="Jan"&WENN(A1=1;"";TEXT(A9&"/99";"-MMM"))
von: IngoG
Geschrieben am: 31.03.2005 16:56:03
Hallo ...
versuchs mal so
Gruß Ingo
Bild

Betrifft: is guuud
von: th.heinrich
Geschrieben am: 31.03.2005 18:35:25
hallo Ingo,
klasse teil
Tabelle3
 AB
11212
2Jan-Dez 
Formeln der Tabelle
B1 : =A1
A2 : ="Jan"&WENN(A1=1;"";TEXT(B1&"/99";"-MMM"))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
Bild

Betrifft: AW: Wenn Formel verlängern
von: ANdreas
Geschrieben am: 31.03.2005 16:44:06
Hallo,
mit einer Formel kann man es so lösen:
="Jan"&WENN(A1>1;"-"&TEXT(DATUM(1;A1;1);"MMM");"")
Gruß
Andreas
Bild

Betrifft: AW: oder mit Funktion Wahl....
von: HermannZ
Geschrieben am: 31.03.2005 17:46:42
Hallo Dallwitz,
wenn in Zelle A1 z.B nur Zahlen stehen dann versuche einmal folgende Formel;
...=WENN(A1<13;WAHL(A1;"Januar";"Februar";"März";"April";"Mai";"Juni";"Juli";"August";"September";"Oktober";"November";"Dezember");"Zahl zu hoch")
Gruß Hermann
Bild

Betrifft: AW: oder mit Funktion Wahl....
von: ransi
Geschrieben am: 31.03.2005 17:54:06
hallo
versuch mal so:
 
 DEFG
11Januar  
22Februar  
33März  
44April  
55Mai  
66Juni  
77Juli  
88August  
99September  
1010Oktober  
1111November  
1212Dezember  
13    
14 benutzerdefiniertes format=MMMM  
Formeln der Tabelle
E1 : =DATUM(JAHR(1900);D1;TAG(1))
E2 : =DATUM(JAHR(1900);D2;TAG(1))
E3 : =DATUM(JAHR(1900);D3;TAG(1))
E4 : =DATUM(JAHR(1900);D4;TAG(1))
E5 : =DATUM(JAHR(1900);D5;TAG(1))
E6 : =DATUM(JAHR(1900);D6;TAG(1))
E7 : =DATUM(JAHR(1900);D7;TAG(1))
E8 : =DATUM(JAHR(1900);D8;TAG(1))
E9 : =DATUM(JAHR(1900);D9;TAG(1))
E10 : =DATUM(JAHR(1900);D10;TAG(1))
E11 : =DATUM(JAHR(1900);D11;TAG(1))
E12 : =DATUM(JAHR(1900);D12;TAG(1))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Bild

Betrifft: AW: oder mit Funktion Wahl....
von: HermannZ
Geschrieben am: 31.03.2005 18:05:55
Hallo ransi,
hat nur den nachteil das bei z.B. eintrag von 13 wieder Januar angezeigt wird.
Gruß hermann
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn Formel verlängern"