Rundungsfehler

Bild

Betrifft: Rundungsfehler von: Thomas G
Geschrieben am: 01.04.2005 08:40:04

Hallo zusammen,

ich brauche eure Hilfe.

Ich bekomme ständig einen Rundungsfehler.

1,94 - 2,07 = -0,13 Das ist soweit in Ordnung

Wenn ich aber nur eine Stelle hinter dem Komma anzeigen lasse
bekomme ich den Rundungsfehler.

1,9 - 2,1 = 0,1 Das angezeigte Ergebniss ist falsch.

Die Zelle mit 1,9 und 2,1 ist mit einem anderen Datenblatt verknüpft.

Wer hat eine Idee wie ich das richtig formatieren kann.

Vielen Dank für euren Tipp

Mit freundlichen Grüßen

Thomas

Bild


Betrifft: AW: Rundungsfehler von: Andi
Geschrieben am: 01.04.2005 08:48:56

Guten Morgen,

Excel rundet nur den angezeigten Wert, gerechnet wird weiterhin mit, ich glaube, 15 Nachkommastellen.

Mit 1,94 in A1 und 2,07 in A2 sollte es so gehen:
=RUNDEN(A1;1)-RUNDEN(A2;1)

Schönen Gruß,
Andi


Bild


Betrifft: AW: Rundungsfehler von: c0bRa
Geschrieben am: 01.04.2005 08:51:14

hallo...

alternativ zu dem 1. vorschlag:

wenn du immer mit den gerundeten werten weiterrechnen willst, dann runde die werte direkt in den beiden zellen... also um den verweis zu deinen quelldaten einfach
=runden(dein quellverweis;1)

Rückmeldung nicht vergessen...
c0bRa


Bild


Betrifft: Danke für die Hilfe von: Thomas G
Geschrieben am: 01.04.2005 08:56:24

Guten Morgen zusammen.

Vielen dank für die Information.
Ich werde sie gleich ausprobieren.

MfG

Thomas


Bild


Betrifft: AW: Rundungsfehler von: serge
Geschrieben am: 01.04.2005 09:01:40

Hi Thomas
1.94 2.07
1.9 2.1
wieso rundest du und formatierst nicht einfach eine Stelle nach dem Komma?
Serge


Bild


Betrifft: AW: Rundungsfehler von: c0bRa
Geschrieben am: 01.04.2005 09:09:03

weil er mit den gerundeten werten weiterrechnen will, und dies eben bei der formatierung nicht geschieht...

formatierung "rundet" zwar fürs auge, aber XL rechnet trotzdem mit den genauen werten weiter...

siehe auch:

https://www.herber.de/bbs/user/20467.xls

Rückmeldung nicht vergessen...
c0bRa


Bild


Betrifft: AW: Rundungsfehler von: Thomas G
Geschrieben am: 01.04.2005 09:21:12

Hallo Serge,

wenn ich so Rund wie Du mir schreibst,
bekomme ich ein falsches Ergebniss.
Excel schreibt dann 0,1 und das ist falsch.

Ich habe mal die Datei mit hochgeladen.
https://www.herber.de/bbs/user/20470.xls


MfG

Thomas


Bild


Betrifft: AW: Rundungsfehler 0,03 oder 0,05 von: Thomas G
Geschrieben am: 01.04.2005 09:53:56

Hallo zusammen,

erstmal danke für euer Feedback.

Ich muß trotzdem noch mal eine Frage zu dem Thema Runden stellen.

Was muß ich anstellen wenn ich hinter der zweiten stelle vom Komma
auf bzw abrunden möchte. Wenn die Zahl kleiner 5 ist, soll der Wert
abgerundet werden. Wenn die Zahl gößer 5 ist, soll der Wert aufgerundet werden.

1,94 - 2,07 = -0,13
1,9 - 2,1 = -0,2


Wer kennt dafür eine Lösung.

Danke für eure Hilfe

MfG

Thomas


Bild


Betrifft: AW: Rundungsfehler 0,03 oder 0,05 von: c0bRa
Geschrieben am: 01.04.2005 10:03:59

also wenn ich dich richtig versteh:

1,345 soll 1,35 ergeben? =runden(1,345;2)
1,344 ergibt dann logischerweise 1,34 mit derselben formel...

andere funktionen sind dann noch aufrunden() und abrunden() funktionieren nach demselben syntax wie runden nur eben dass immer auf bzw abgerundet wird...

c0bRa


Bild


Betrifft: AW: Rundungsfehler 0,03 oder 0,05 von: serge
Geschrieben am: 01.04.2005 10:09:44

Thomas
Willst du jetzt mit genauen Werten rechnen oder die Abrundung vergewaltigen?
Serge


Bild


Betrifft: AW: Rundungsfehler 0,03 oder 0,05 von: Thomas G
Geschrieben am: 01.04.2005 10:23:03

Hallo,

tut mir leid wenn ich denn Tread wegen so einer Frage in die länge ziehe.

Ich habe jetzt schon verschiedene Möglichekeiten ausprobiert.
Aber leider habe ich nicht das Ergebniss bekommen was ich brauche.

Wenn ich 1,94 abrunde bekomme ich 1,9(da die 4 kleiner als 5 ist runde ich ab)
Wenn ich 2,07 aufrunde bekomme ich 2,1 (da die 7 grösser als 5 ist runde ich auf)

Wenn ich jetzt per Hand rechne sind 1,9 - 2,1 = -0,2

Gib die obigen Zahlen mal in Excel ein und Runde die Zahlen per Formel.
Das Ergebniss stimmt nicht.

Vieleicht befinde ich mich ja auf den Holzweg.

Trotzdem danke für die Hilfe

MfG

Thomas


Bild


Betrifft: AW:und wo ist das Probelm?? von: HermannZ
Geschrieben am: 01.04.2005 10:27:13

Hallo Thomas,

ein Beispiel;

Summe
 ABCD
22191,92,1 -0,13
Formeln der Tabelle
D2219 : =A2219-B2219
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


Bild


Betrifft: AW: Rundungsfehler 0,03 oder 0,05 von: c0bRa
Geschrieben am: 01.04.2005 10:27:45

https://www.herber.de/bbs/user/20475.xls


Bild


Betrifft: Problem gelöst DANKE von: Thomas G
Geschrieben am: 01.04.2005 10:31:38

Hallo zusammen,

vielen Danke für eure Mühe und Geduld.

Das Problem ist gelöst.

MfG

Thomas


Bild


Betrifft: eigentlich hab ich jetzt ein April April erwartet von: c0bRa (oT)
Geschrieben am: 01.04.2005 10:35:04

*eg*


Bild


Betrifft: AW: Rundungsfehler 0,03 oder 0,05 von: serge
Geschrieben am: 01.04.2005 10:32:36

ich habe es versuch und komme nicht auf deine Problem!
https://www.herber.de/bbs/user/20476.xls
Serge


Bild


Betrifft: Sorry von: Thomas G
Geschrieben am: 01.04.2005 10:51:27

Hallo,

tut mir leid aber ich glaube mein Rechner hatt mit mir
ein April Scherz erlaubt.

Ich habe mir auch schon gedacht das so ein kleines Problem
schnell gelöst sein sollte. Habe mir wohl selber im Weg gestanden.

Daher gehe ich jetzt nach Hause. Ist wohl für heute besser so.

Noch mals danke für eure Hilfe.

MfG

Thomas


Bild


Betrifft: jetzt schon nach Hause...?? von: Andi
Geschrieben am: 01.04.2005 11:03:06

guck mal hier, was andere Leute für Arbeitszeiten haben :-)
https://www.herber.de/forum/messages/593048.html


Bild


Betrifft: AW: jetzt schon nach Hause...?? von: HermannZ
Geschrieben am: 01.04.2005 11:09:22

Hallo Thomas,

ist doch April oder???
siehe hier,
Summe
 ABC
2234   
22351,941,90-0,20
22362,072,10 
2237   
2238 -0,200,13
2239 -0,10-0,13
2240   
Formeln der Tabelle
B2235 : =RUNDEN(A2235;1)
C2235 : =B2235-B2236
B2236 : =RUNDEN(A2236;1)
B2238 : =RUNDEN(A2235;1)-RUNDEN(A2236;1)
C2238 : =OBERGRENZE(ABS(A2235-A2236);0,005)
B2239 : =RUNDEN(A2235-A2236;1)
C2239 : =OBERGRENZE(A2235;0,005)-OBERGRENZE(A2236;0,005)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Gruß Hermann


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bereich (Größe dynamisch) markieren"