Herbers Excel-Forum - das Archiv

Werte zwischen Grenzen ermitteln

Bild

Betrifft: Werte zwischen Grenzen ermitteln
von: Stefan Schumann

Geschrieben am: 06.04.2005 01:25:19
Hallo zusammen,
in meiner Spalte A stehen die 'von'-, in Spalte B die 'bis einschließlich'-Werte, in Spalte C der zugehörige Korrekturwert.
Ich möchte nun z.B. in E2 eine Zahl eingeben. In F2 soll mir Excel an hand der von-bis-Werte automatisch den zugehörigen Korrekturwert, mit dem ich dann weiterrechnen will, reinschreiben.
Wie geht das?
Vielen Dank für Hinweise.
Gruß,
Pampel
Bild

Betrifft: AW: Werte zwischen Grenzen ermitteln
von: Jörg Gradert
Geschrieben am: 06.04.2005 02:09:28
Hallo Stefan,



=SUMMENPRODUKT((A2:A4<=D2)*(B2:B4>=D2)*C2:C4)
Die Formel bezieht sich auf meine Beispieltabelle, Du mußt die Bezüge an deine Erfordernisse anpassen.
Gruß Jörg
Bild

Betrifft: AW: Werte zwischen Grenzen ermitteln
von: Stefan Schumann
Geschrieben am: 06.04.2005 02:41:01
Hallo Jörg,
vielen Dank für die Antwort zu dieser Stunde. Paßt perfekt.
Gruß,
Stefan
 Bild
Excel-Beispiele zum Thema "Werte zwischen Grenzen ermitteln"
Zwischensumme als Text Gefilterte Daten ohne Zwischenablage übertragen
Werte ohne Zwischenspeicher übertragen Variable in Zwischenablage übernehmen
Variablen in einer temporären Textdatei zwischenspeichern Zwischensumme in Fußzeile
Zwischensummen eintragen Zwischen zwei UserForms wechseln, wobei sich die 1. Aktualisiert
Werte aus UserForm-ListBox in die Zwischenablage übernehmen Startzeit und auf Schaltflächendruck Zwischenzeiten eintragen