Mittelwertberechnung bei Filterauswahl

Bild

Betrifft: Mittelwertberechnung bei Filterauswahl
von: Marius
Geschrieben am: 12.04.2005 09:42:45
servus
beim untenstehenden beispiel habe ich mit der mittelwertformel das resultat (55.00) errechnet. auf der spalte [Text] habe ich die Filterfunktion aufgeschaltet. ich möchte nun z.B. mittels Filter die Zeilen mit dem Buchstaben "A" auswählen und die für die mittelwertberechnung dürfte es dann auch nur die Zahlen der Zeile A verwenden. Gibt für dieses Problem eine Lösung?
Vielen dank zum voraus.
Marius
Text Zahl
A 10.00
B 10.00
C 10.00
D 10.00
A 50.00
A 100.00
B 50.00
A 200.00
Mittelwert = 55.00

Bild

Betrifft: AW: Mittelwertberechnung bei Filterauswahl
von: HermannZ
Geschrieben am: 12.04.2005 09:53:28
Hallo Marius,
meinst du das so??
Beispiel;
Versuch
 ABCDE
19KennungWertges. Kennung  
20A10A90<< Mittelwert
21B10   
22C10   
23D10   
24A50   
25A100   
26B50   
27A200   
28     
Formeln der Tabelle
D20 : {=MITTELWERT(WENN(A20:A27=C20;B20:B27))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: Mittelwertberechnung bei Filterauswahl
von: EtoPHg
Geschrieben am: 12.04.2005 10:09:28
Hallo Marius,
Wenn Du einen Autofilter verwendest, schreibe folgende Formel (statt Deinem =Mittelwert) in die erste freie Zelle der Kolonne mit den Zahlen (Beispiel Kolonne B)
=TEILERGEBNIS(1;B2:B9)
Dieses liefert den Mittelwert der gefilterten Werte.
Gruss Hansueli
 Bild

Beiträge aus den Excel-Beispielen zum Thema "0001 wert in zelle eingeben ohne Format zu ändern"