Eleganter als SUMIF

Bild

Betrifft: Eleganter als SUMIF
von: Vitor Grosso
Geschrieben am: 19.04.2005 13:05:35
Liebe Gruessen Aus Portugal an allen Excelianer,
Moechte gern eure Hilfe in Anspruch nehmen. Ich habe eine zwei einfachen listen/spalten nebeneinnader, sagen wir mal, mit 100 eintraege jede, die erste spalte hat entweder das Wort "Ja" oder "Nein", und die zweite spalte hat negative und positive werte (zahlen) und moechte zuerst folgendes:
Addiere die positive Zahlen der zweite spalte wenn auf die erste das "ja" steht.
Noch besser waere eine formel wo die vier moeglichkeiten berechnet wuerden.
JA und Positive, Ja und Negative, Nein und Positive, Nein und Negative.
Mfg
Vito





Bild

Betrifft: =SUMMENPRODUKT((A1:A100="ja")*(B1:B100>0))
von: WF
Geschrieben am: 19.04.2005 13:16:19
.
Bild

Betrifft: AW: =SUMMENPRODUKT((A1:A100="ja")*(B1:B100>0))
von: Vitor Grosso
Geschrieben am: 19.04.2005 13:37:51
Liebe(r) WF,
Vielen Dank im vorraus fuer deine Hilfe, aber folgendes, gesucht wird sie summe der Bertraege und nicht die anzahl der Bertraege die bestimmt kondition befriedigen.
mfg aus lissabon
vito

Bild

Betrifft: Summe statt Anzahl
von: WF
Geschrieben am: 19.04.2005 13:42:33
Hi Vito,
=SUMMENPRODUKT((A1:A100="ja")*(B1:B100>0)*B1:B100)
Salut WF
Bild

Betrifft: Obrigado (Vielen Dank auf pt)
von: Vitor Grosso
Geschrieben am: 19.04.2005 13:49:38
genial
Bild

Betrifft: AW: Eleganter als SUMIF
von: Galenzo
Geschrieben am: 19.04.2005 13:20:43
Nimmst du eine Pivottabelle.
Viel Erfolg!
Bild

Betrifft: AW: Eleganter als SUMIF
von: Waltraud
Geschrieben am: 19.04.2005 13:34:37

=SUMMENPRODUKT((A:A="ja")*(B:B>0);B:B)
Bild

Betrifft: AW: Eleganter als SUMIF
von: Vitor Grosso
Geschrieben am: 19.04.2005 13:45:23
Liebe Waltraud,
Einfach Genial, vielen dank aus Lissabon.
Mfg.
Vito

Bild

Betrifft: AW: Eleganter als SUMIF
von: Vitor Grosso
Geschrieben am: 19.04.2005 13:45:53
Liebe Waltraud,
Einfach Genial, vielen dank aus Lissabon.
Mfg.
Vito

Bild

Betrifft: komplette Spalten (A:A) funktioniert nicht
von: WF
Geschrieben am: 19.04.2005 13:50:37
.
Bild

Betrifft: Wer sagt das denn?
von: Boris
Geschrieben am: 19.04.2005 14:52:01
Hi Walter,
das hatten wir doch grade erst:
http://www.excelformeln.de/formeln.html?welcher=395
;-))
Grüße Boris
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Duplikate zeilenweise löschen"