Benutzerspezifische Formel

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Frame
Bild

Betrifft: Benutzerspezifische Formel
von: Leckelt
Geschrieben am: 20.04.2005 18:40:28
Hallo,
Nach vielem hin und her hab ich nun eine Möglickeit gefunden mein Problem zu lösen. Leider ist die Formel dafür etweas lang geworden.
Bekomm ich die in ene benutzerspezivische Formel.
=WENN(ABRUNDEN(Fr2sec(A7;30)-Fr2sec(A6;30);2)>60;VERKETTEN(ABRUNDEN(ABRUNDEN(Fr2sec(A7;30)-Fr2sec(A6;30);2)/60;0);":";ABRUNDEN(Fr2sec(A7;30)-Fr2sec(A6;30);2)-(ABRUNDEN(ABRUNDEN(Fr2sec(A7;30)-Fr2sec(A6;30);2)/60;0)*60));VERKETTEN(0;":";ABRUNDEN(Fr2sec(A7;30)-Fr2sec(A6;30);2)))
https://www.herber.de/bbs/user/21371.xls
Wobei die Startspalte noch relativ einzugeben wäre, da meine exportierte Timecodetabelle nicht immer in A1 beginnt.
Leider hab ich von VBA keine Ahnung.

vielen Dank
Losche

Bild

Betrifft: AW: Benutzerspezifische Formel
von: Gert Seler
Geschrieben am: 20.04.2005 22:42:58
Hallo Losche,
was soll den berechnet werden?
In der Tabelle werden bestimmte Zeitwerte von anderen subtrahiert.
Warum?
Bitte mehr Details.
mfg
Gert
Bild

Betrifft: AW: Benutzerspezifische Formel
von: Leckelt
Geschrieben am: 20.04.2005 23:32:21
hallo gert
Aus einem Musicsequencer bekomm ich eine Timecodeliste mit Zeiten in der Form hh:mm:ses:fr
(1Frame = 1/30 sec).
Wenn ich jetzt dazu eine Show programieren will, setz ich mir im Sequenzer auf den Charakter der Musik bestimmte Marken die ich dann über die Timecodeliste rausbekomme. (Spalte A)
Um jetzt in "verständlichen" Zeiten Denken zu können muss ich halt die Zeiten von einander abziehen um dann in die Form von min:sec,00 (Spalte H) zu kommen.
Ich hoffe es hat Dir etwas weitergeholfen um mir Helfen zu konnen
Gruß
Losche
Bild

Betrifft: AW: Benutzerspezifische Formel
von: Gert Seler
Geschrieben am: 21.04.2005 00:42:08
Hallo Losche,
die lange Formel ist nicht nötig, da die Berechnung bereits in Spalte F
und das Ergebnis in Spalte G erscheint.
Mit der folgenden Formel wird in Spalte H die Zeit umgerechnet:
=WENN(UND($F3=0;$G3="");"";WENN($G3>60;$G3/60;$G3/100))
Das Ergebnis als 4stellige Zahl formatieren. Vor dem Komma =Minuten, die ersten
2 Zahlen danach=Sekunden, die letzten beiden Zahlen=zehntel und hundertstel
Sekunden.
mfg
Gert
Bild

Betrifft: AW: Benutzerspezifische Formel
von: Leckelt
Geschrieben am: 21.04.2005 01:45:24
Hallo Gert,
sowohl die Spalte F als auch die Spalte G waren für mich nur Hilfsschritte um die Spalte H generieren zu können. Aus dem Sequencer kommt nur die Spalte A. Das heisst: Ich müsste jedesmal die "Hilfsspalten" bauen. Das wollt ich mir mit der langen Formel ersparen wenn ich sie irgendwie - als Makro,VBA, oder irgendetwas was Excel noch so bietet und ich nicht verstehe - mit einem Befehl einfügen und dann einfach nur die bis zu 1.000 Zeiten runterkopieren kann.
Gruß Losche
Bild

Betrifft: AW: Benutzerspezifische Formel
von: Leckelt
Geschrieben am: 21.04.2005 01:37:58
hallo gert
Aus einem Musicsequencer bekomm ich eine Timecodeliste mit Zeiten in der Form hh:mm:ses:fr
(1Frame = 1/30 sec).
Wenn ich jetzt dazu eine Show programieren will, setz ich mir im Sequenzer auf den Charakter der Musik bestimmte Marken die ich dann über die Timecodeliste rausbekomme. (Spalte A)
Um jetzt in "verständlichen" Zeiten Denken zu können muss ich halt die Zeiten von einander abziehen um dann in die Form von min:sec,00 (Spalte H) zu kommen.
Ich hoffe es hat Dir etwas weitergeholfen um mir Helfen zu konnen
Gruß
Losche
Bild

Betrifft: AW: Benutzerspezifische Formel
von: Gert Seler
Geschrieben am: 21.04.2005 11:12:02
Hallo Losche,
blende die Hilfsspalten aus. Spalten markieren, rechte Maustaste, ausblenden
wählen. In VBA kann ich Dir nicht weiterhelfen.
mfg
Gert
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Benutzerspezifische Formel"