INDIREKT Formeln zusammensetzen

Bild

Betrifft: INDIREKT Formeln zusammensetzen
von: Nils
Geschrieben am: 20.04.2005 21:11:09
Hallo Forum,
ich möchte gern auf einem Arbeitsblatt die Bereiche für Summenformeln hinterlegen und dann von anderen Arbeitsblättern darauf INDIREKT zugreifen.
Tabelle1, A1: (A675:A800;A12;B123:B456)
Tabelle2, A1: =SUMME(INDIREKT(Tabelle1!A1))
Ich habe insgesamt ca. 200 dieser Summenformeln, die in verschiedenen Kombinationen in ca. 50 Tabellenblättern (wie im Bespiel Tabelle2) vorkommen.
Ein indirekter Bezug würde die ganze Arbeitsmappe sehr schön transparent und variabel gestalten und Änderungen in den Summenformeln erleichtern (die regelmässig vorgenommen werden müssen).
Ich wäre über eine Lösung sehr dankbar
Gruss aus Brüssel

Bild

Betrifft: =SUMME(Nils)
von: Boris
Geschrieben am: 20.04.2005 21:25:56
Hi Nils,
damit die Betreffformel auch funktioniert:
Strg+F3 (Namen definieren), Name: Nils
Bezieht sich auf:
=AUSWERTEN(Tabelle1!$A$1)
Die Klammern um die Bezüge in A1 kannst du übrigens weglassen.
Grüße Boris
Bild

Betrifft: AW: =SUMME(Nils)
von: Nils
Geschrieben am: 20.04.2005 21:45:43
Hallo Boris,
der Fehler ist weg, soweit so gut, aber eine Berechnung der auf Tabelle1 angegebenen Zellen in Tabelle2 erfolgt nicht. Wenn ich nur einen Bezug eingebe
(in Tabelle1 A1: "A755:A800") dann klappt der indirekte Bezug.
Hat noch jemand eine Idee für eine zusammengesetzte Summenformel?
Bild

Betrifft: Ich hab nix von INDIREKT geschrieben...
von: Boris
Geschrieben am: 20.04.2005 21:52:59
Hi Nils,
...was mich zur der Annahme verleitet, dass du meine Erklärung nicht richtig umgesetzt hast...
Grüße Boris
Bild

Betrifft: Richtig, nicht indirekt
von: Nils
Geschrieben am: 20.04.2005 22:02:33
aber deine Lösung funktioniert nicht, mag sein, dass ich sie falsch umgesetzt habe.
Folgendes habe ich getan:
In Tabelle1, A1 (jetzt "NILS") steht: A123:B345;A7;C12
In Tabelle2, A1 steht: =SUMME(NILS) und der Wert 0 wird ausgegeben. Ich will aber ja in Tabelle2 folgendes berechnen: SUMME(A123:B345;A7;C12)...
Wo liegt mein Fehler?
Bild

Betrifft: Du hast die Hauptsache vergessen...
von: Boris
Geschrieben am: 20.04.2005 22:17:37
Hi Nils,
...und zwar das =AUSWERTEN(...)
Der Name Nils wird vergeben mit Strg+F3 (Name definieren), und unten steht dann noch so ne Zeile "Bezieht sich auf..." - und dort gibst du =AUSWERTEN(...) ein.
Die Zelle Tabelle1!A1 selbst hat keinen Namen!
Grüße Boris
Bild

Betrifft: Beispielmappe
von: Boris
Geschrieben am: 20.04.2005 22:34:09
Hi Nils,
https://www.herber.de/bbs/user/21453.xls
Grüße Boris
Bild

Betrifft: AW: Beispielmappe
von: Beate Schmitz
Geschrieben am: 21.04.2005 00:40:36
Lieber Boris,
habe deine Datei mal angeschaut. Es geht! Solange man im gleichen Blatt ist. Benutzt man
=SUMME(Nils) in einem anderen Blatt (und das will Nils ja), ist das Ergebnis 0.
Ich habe rausgefunden, wenn man in A1 auch den Tabellenblattnamen zufügt, geht es auch blattübergreifend, also in A1:
Tabelle1
 AB
1Tabelle1!C1;Tabelle1!D4:D6;Tabelle1!F11:G12 
 

Insgesamt: Nette Lösung!
Gruß,
Beate
Bild

Betrifft: Blattname in Auswertungszelle @Beate&Boris
von: Luc:-?
Geschrieben am: 21.04.2005 01:33:09
Hallo Beate & Boris,
interessante Lösung, nie davon gehört und auch nicht in der Hilfe gefunden. Aber...
so wie von dir angegeben, Beate, funktioniert's auf einem anderen Blatt. Wenn aber Werte aus verschiedenen Blättern summiert werden sollen, muss ein + zwischen die verschiedenen Blattbezüge gesetzt wdn, damit es funktioniert. Wenn man dann noch Summe weglässt, wdn Werte gleicher Zellen addiert. Alles als Matrixformel geschrieben, werden sie dann auch ausgegeben.
Was allerdings so nicht fkt. sind Schreibweisen wie Tabelle1:Tabelle3!A1:A5. Da sowas auch mit INDIREKT nicht fkt., greife ich in solchen Fällen lieber auf meine Ersatzfunktion TinRange zurück, die ich in einer früheren Version hier schon veröffentlicht habe.
Gruß Luc
:-?
Bild

Betrifft: @Boris, Beate & Luc
von: Nils
Geschrieben am: 21.04.2005 09:20:34
Hallo Freunde,
vielen Dank für eure Hilfe, leider bin ich immer noch nicht weiter:
Denn Boris Lösung funktioniert nur auf dem gleichen Sheet und Beates Lösung ist nicht ptaktikabel, da ich ca. 50 Sheets und 200 Summenformeln habe, in die ich nicht jedesmal die
Bezüge 'TabelleXY!' einfügen kann...
@LUC: wie funktioniert die TINRANGE Funktion? Ich konnte diese im Archiv nicht finden.
Ich wäre sehr dankbar für eine schicke Lösung
Gruss
Bild

Betrifft: Und so geht´s für alle Tabellen
von: Boris
Geschrieben am: 21.04.2005 10:57:30
Hi Nils,
in Tabelle1!A1 gibst du die Bereiche vor - z.B.:
A1:B10;F20;H30:I40
Jetzt definiere den Namen Nils, der sich hierauf bezieht:
=AUSWERTEN(TEIL(WECHSELN(";"&Tabelle1!$A$1;";";";"&TEIL(ZELLE("Dateiname";INDIREKT("A1"));FINDEN("]";ZELLE("Dateiname";INDIREKT("A1")))+1;31)&"!");2;999))
Wenn du jetzt in Tabelle2 irgendwo die Formel =SUMME(Nils) eingibst, dann werden dort die Bereiche A1:B10;F20;H30:I40 aus Tabelle2 summiert. Gibst du die Formel in Tabelle15 ein, dann eben aus Tabelle15 - usw. usw.
Damit das funktioniert, muss die Mappe mindestens 1 mal gespeichert worden sein, da sonst ZELLE("Dateiname"...) ins Leere läuft!
Grüße Boris
Bild

Betrifft: WOW: Und so geht´s für alle Tabellen
von: MichaV
Geschrieben am: 21.04.2005 11:09:58
AUSWERTEN(TEIL(WECHSELN(";"&Tabelle1!$A$1;";";";"&TEIL(ZELLE("Dateiname";INDIREKT("A1"));FINDEN("]";ZELLE("Dateiname";INDIREKT("A1")))+1;31)&"!");2;999))
Hi Boris,
ich möchte Dir an dieser Stelle mal meinen großen Respekt aussprechen ;o)
Hab mich schon öfter gefragt, ob die Excel- Macher überhaupt wissen, was man mit ihren Formeln so alles anstellen kann.
Gruß! Micha
Bild

Betrifft: AW: @Boris, Beate & Luc
von: Luc:-?
Geschrieben am: 21.04.2005 22:29:49
Hallo Nils,
Fkt steht unter Betrifft: AW: zum zweiten Punkt von: Luc :-? Geschrieben am: 04.03.2005 19:59:23 zu Funktion gesucht von Lorenz vom 04.03.2005 14:19:03 https://www.herber.de/forum/archiv/580to584.htm
Gruß Luc :-?
 Bild

Beiträge aus den Excel-Beispielen zum Thema "INDIREKT Formeln zusammensetzen"