mehrere suchbegriffe, 1 ergebnis-code

Bild

Betrifft: mehrere suchbegriffe, 1 ergebnis-code
von: leo
Geschrieben am: 21.04.2005 01:06:29
liebe excelfreunde,
ich habe viele zeilen mit je 8 waagrecht a bis h-spalte befüllten zellen (buchstaben oder zahlen) abzufragen um dann dann einen vorgegebenen Code der 9. zelle i-spalte (daneben) zu erhalten.
die suchbegriffe bestehen auch aus 8 zellen (buchstaben oder zahlen).
wenn die reihenfolge/inhalte der zellen a bis h mit den suchbegriffen
der zellen m1 bis t1 übereinstimmen, so soll der code/ergebnis der selben waagrechten reihe (i-spalte - daneben) in der formelzelle ausgewiesen werden.
die frage war wahrscheinlich noch nicht gestellt oder anders gestellt, da ich diese auf der excel-cd nicht gefunden habe.

Bild

Betrifft: AW: mehrere suchbegriffe, 1 ergebnis-code
von: Beate Schmitz
Geschrieben am: 21.04.2005 01:29:49
Hallo Leo,
Tabelle1
 ABCDEFGHI
1Wert1Wert2Wert3Wert4Wert5Wert6Wert7Wert8Treffer: gleiche Zellinhalte und gleiche Reihenfolge wie M$1:T$1:
2KupferHolzMetallPlastik124485Pferd 
3Metall6467Pferd99878696Metall 64 67 Pferd 99 87 86 96
4Plastik134929MetallPferd434 
Formeln der Tabelle
I2 : {=WENN(UND(A2:H2=M$1:T$1);A2&" "&B2&" "&C2&" "&D2&" "&E2&" "&F2&" "&G2&" "&H2;"")}
I3 : {=WENN(UND(A3:H3=M$1:T$1);A3&" "&B3&" "&C3&" "&D3&" "&E3&" "&F3&" "&G3&" "&H3;"")}
I4 : {=WENN(UND(A4:H4=M$1:T$1);A4&" "&B4&" "&C4&" "&D4&" "&E4&" "&F4&" "&G4&" "&H4;"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 

Gruß,
Beate
Bild

Betrifft: AW: mehrere suchbegriffe, 1 ergebnis-code
von: Rolf Beißner
Geschrieben am: 21.04.2005 10:01:16
Hallo Beate,
das "UND" verstehe ich nicht.
Als Alternative hier mal eine
benutzerdefinierte Funktion -
aus meinem Bauchladen.
Herzliche Grüße
Rolf

Function zustring(r As Integer, c1 As Integer, cn As Integer) As String
'r=Zeile,c1=Beginn-,cn=Endespalte
Dim i  As Integer
    zustring = ""
    For i = c1 To cn
        zustring = zustring & Cells(r, i)
    Next
End Function

Bild

Betrifft: AW: mehrere suchbegriffe, 1 ergebnis-code
von: Beate Schmitz
Geschrieben am: 21.04.2005 11:02:36
Hallo Rolf,
meine Lösung basierte darauf, das Gleiche in der gleichen Reihenfolge WAHR ergeben.
Bei Interesse: Die Lösung basierte auf folgendem Thread:
http://www.excel-center.de/foren/read.php?2,366,405#msg-405
Dies geht aber auch:
Tabelle1 (2)
 ABCDEFGHI
1Wert1Wert2Wert3Wert4Wert5Wert6Wert7Wert8Treffer: gleiche Zellinhalte und gleiche Reihenfolge wie M$1:T$1
2KupferHolzMetallPlastik124485Pferd 
3Metall6467Pferd99878696Metall 64 67 Pferd 99 87 86 96
4Plastik134929MetallPferd434 
Formeln der Tabelle
I2 : =WENN(SUMMENPRODUKT(N(A2:H2=L$1:S$1))<8;"";A2&" "&B2&" "&C2&" "&D2&" "&E2&" "&F2&" "&G2&" "&H2)
I3 : =WENN(SUMMENPRODUKT(N(A3:H3=L$1:S$1))<8;"";A3&" "&B3&" "&C3&" "&D3&" "&E3&" "&F3&" "&G3&" "&H3)
I4 : =WENN(SUMMENPRODUKT(N(A4:H4=L$1:S$1))<8;"";A4&" "&B4&" "&C4&" "&D4&" "&E4&" "&F4&" "&G4&" "&H4)
 

Ich geh davon aus, dass deine Funktion auch läuft. Aber wie muss die Formel lauten? Krieg es nicht hin.
Aber abgesehen davon: Excelfunktionen müßten doch (wenn vorhanden) den benutzerdef. aufgrund von Tempo vorzuziehen sein, oder?
Gruß,
Beate
Bild

Betrifft: AW: mehrere suchbegriffe, 1 ergebnis-code
von: Rolf Beißner
Geschrieben am: 21.04.2005 11:34:35
Hallo Beate,
danke für die Nachhilfe -
jetzt hab' ich das "UND" kapiert -
das ist natürlich die bessere Lösung.
Meine Funktion liefert als Wert
einen String der nebeneinanderliegenden Zellen,
die durch die Argumente Zeile, Start- und Endespalte
definiert werden -
kannst du aber in diesem Zusammenhang, s.o., vergessen.
Herzliche Grüße + schönen Tag
Rolf
 Bild

Beiträge aus den Excel-Beispielen zum Thema "mehrere suchbegriffe, 1 ergebnis-code"