Spaltenvergleich

Bild

Betrifft: Spaltenvergleich
von: Demian
Geschrieben am: 25.04.2005 14:43:43
Hallo
folgendes Problem: In der angehängten Bsp-Datei würde ich gerne die Spalten 2003 und 2004 miteinander vergleichen und in "Ausw def" angeben, wass sich zwischen den jahren an Zu- und Abgängen so getan hat. Problem ist, es geht nicht nur um die absolute Zahl, sondern auch um die Art des Eintrages. Diese müßte man anhand von Splate A festmachen. Hier ist die "114" weggefallen und die "117" dazugekommen. D. h. in "Ausw def" müßten für 2003 und auch für 2004 "3" angezeigt werden, aber dennoch 1 Zugang und 1 Abgang. Kann man das mit einer Formel machen oder braucht man dafür eine VBA-Prozedur? Wäre für einen Tip dankbar.
Gruß, Demian

Bild

Betrifft: Datei fehlt o.w.T.
von: Reinhard
Geschrieben am: 25.04.2005 14:44:52

Bild

Betrifft: Spaltenvergleich
von: Demian
Geschrieben am: 25.04.2005 14:44:54
Datei muss noch dazu...
https://www.herber.de/bbs/user/21670.xls
Bild

Betrifft: Spaltenvergleich
von: Demian
Geschrieben am: 25.04.2005 15:11:43
Hallo,
vielleicht kann man zunächst nur Sp. A von 2003 und Sp. A von 2004 miteinander vergleichen (ohne Bezug zu Sp. B) und sagen, wie viele dazugekommen und wie viele abgegangen sind? So als 1. Schleife?
Hat nicht jemand zumindest einen Anfang? Habe so Schleifen noch nie gemacht.
https://www.herber.de/bbs/user/21670.xls

Gruß, demian
Bild

Betrifft: Spaltenvergleich
von: Demian
Geschrieben am: 25.04.2005 15:20:36

Function Spaltenvergleich(Nr As String, Spalte As Byte)
    Dim Suchbereich As Range
    Dim Anzahl As Long
    Dim x As Long
    
    ' und jetzt könnte man doch als suchbereich spalte a von "2003 und sp A von "2004" angeben und ungefähr so
Anzahl derer, die Nr("2003") = Nr("2004")als Zahl in Worksheets("Ausw").Range("B8")
Anzahl derer, für die gilt Nr("2003") NICHT GLEICH Nr ("2004") als Zahl in Worksheets("Ausw").Range("B9")
End Function

Irgendwie so. Probiere es weiter. Wäre, wie gesagt, über einen kleinen Tip dankbar.
Grüße, DEMIAN
Bild

Betrifft: AW: Spaltenvergleich
von: Tinu
Geschrieben am: 25.04.2005 15:24:01
Hallo Demian
hab die eine Lösung mit Hilfsblatt aber ohne VBA hochgeladen
https://www.herber.de/bbs/user/21671.xls
Gruss
Tinu
Bild

Betrifft: AW: Spaltenvergleich
von: Demian
Geschrieben am: 25.04.2005 15:51:57
Hi Tinu,
ersteinmal herzlichen Dank für Deine Hilfe. Funktioniert in Deinem Bsp auch sehr gut. Ich habe allerdings das Problem, dass mir bei folgender Formel
=ZÄHLENWENN(Ausw1!A2:A150;"<>""") bzw.
=ZÄHLENWENN(Ausw2!A2:A150;"<>""")
'149' angezeigt wird, obwohl in "Ausw1" 82 Daten stehen, in "Ausw2" aber nur 73. Ist es vielleicht ein Problem, dass in Sp A die Zahlen lediglich angezeigt werden, hinterlegt aber Formeln sind? Habe es bereits mit WENN(ISTFEHLER(etc. probiert, klappt trotzdem nicht.
Bei
=ZÄHLENWENN(Ausw1!F:F;"n")
wird auch immer eine Null angezeigt - kann aber nicht sein. Wofür stehen denn F:F und "n"?
Grüße, DEMIAN
Bild

Betrifft: AW: Spaltenvergleich
von: Demian
Geschrieben am: 25.04.2005 16:16:31
Hi Tinu,
ersteinmal herzlichen Dank für Deine Hilfe. Funktioniert in Deinem Bsp auch sehr gut. Ich habe allerdings das Problem, dass mir bei folgender Formel
=ZÄHLENWENN(Ausw1!A2:A150;"<>""") bzw.
=ZÄHLENWENN(Ausw2!A2:A150;"<>""")
'149' angezeigt wird, obwohl in "Ausw1" 82 Daten stehen, in "Ausw2" aber nur 73. Ist es vielleicht ein Problem, dass in Sp A die Zahlen lediglich angezeigt werden, hinterlegt aber Formeln sind? Habe es bereits mit WENN(ISTFEHLER(etc. probiert, klappt trotzdem nicht.
Bei
=ZÄHLENWENN(Ausw1!F:F;"n")
wird auch immer eine Null angezeigt - kann aber nicht sein. Wofür stehen denn F:F und "n"?
Grüße, DEMIAN
Bild

Betrifft: AW: Spaltenvergleich
von: Tinu
Geschrieben am: 25.04.2005 19:04:08
Hallo Demian
sorry für den Unterbruch.
Du beziehst Dich offensichtlich auf die Version von Reinhard. Nun, wenn Du in Spalte A Formeln hast, dann solltest Du statt "<>""" besser "<>0" eingeben. In Spalte F musst Du die Schriftfarbe auf Auto stellen, damit du siehst, was in den Zellen steht. j steht für JA, n für NEIN. Ich finde dies übrigens sehr gefährlich, in Spalten zu rechnen und die Schriftfarbe auf weiss zu stellen um die Anzeige zu unterdrücken. So besteht die Gefahr, dass die Formeln überschrieben werden.
Gruss
Tinu
Bild

Betrifft: Excellösung mit Hilfsspalte
von: Reinhard
Geschrieben am: 25.04.2005 15:23:52
Hallo Demian
https://www.herber.de/bbs/user/21672.xls
Gruß nach Salzgitter :-)
Reinhard
Bild

Betrifft: AW: Excellösung mit Hilfsspalte
von: Demian
Geschrieben am: 25.04.2005 15:32:49
Danke für die Datei. Werde mich jetzt damit beschäftigen und versuchen zu verstehen. Salzgitter habe ich allerdings nicht verstanden. Who are you?
Bild

Betrifft: AW: Excellösung mit Hilfsspalte
von: Reinhard
Geschrieben am: 25.04.2005 16:08:27
Hallo Demian,
Datei---Eigenschaften *g
Gruß
Reinhard
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Anzeige verhindern"