Microsoft Excel

Herbers Excel/VBA-Archiv

Zeichenfolge vergleichen und Unstimmigkeiten marki

Betrifft: Zeichenfolge vergleichen und Unstimmigkeiten marki von: martin
Geschrieben am: 05.10.2005 09:51:53

Hallo Excel-Kenner und Könner,

ich habe folgendes Problem:

ich möchte in einer Tabelle die Zeichenfolge mit den vorgegeben Standards vergleichen. In meinem Beispiel sind in der Spalte "B" der Tabelle "Worksheet" beliebige Zeichenfolgen, die mit dem "Standard" der Spalte "A" in Tabelle "Master" verglichen werden sollen. Dabei spielt es keine Rolle, ob hinter dem "GA1" in Zeile 7 noch Leerzeichen oder andere Zeichen kommen,d.h. es sollen nur die ersten 3 "Ziffern" verglichen werden.
Das Ergebnis dieses Vergleiches soll in "Worksheet" in Spalte "C" als "OK" oder "falsch" ausgegeben werden.

https://www.herber.de/bbs/user/27211.xls

Wer kann mir weiterhelfen und mein Problem lösen?

Danke!
Martin

  


Betrifft: AW: Zeichenfolge vergleichen und Unstimmigkeiten marki von: MichaV
Geschrieben am: 05.10.2005 09:56:49

Hallo,

in E2 diese Formel:
=WENN(ZÄHLENWENN(Master!$A$2:$A$10;worksheet!D2);"OK";"falsch")

und runterkopieren.

Gruß- Micha

PS: Rückmeldung wäre nett.


  


Betrifft: neee, so ist besser ;o) von: MichaV
Geschrieben am: 05.10.2005 10:01:59

Hallo,

sorry, ich war mir zu schnell.

=WENN(ZÄHLENWENN(Master!$A$2:$A$10;GLÄTTEN(LINKS(B2;3)));"OK";"falsch")

Gruß- Micha

PS: Rückmeldung wäre nett.


  


Betrifft: AW: neee, so ist besser ;o) von: martin
Geschrieben am: 05.10.2005 13:14:32

super!!

vielen Dank!

Gruss Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Zeichenfolge vergleichen und Unstimmigkeiten marki"