Herbers Excel-Forum - das Archiv

Summe Datumabhängig

Bild

Betrifft: Summe Datumabhängig
von: ullido

Geschrieben am: 12.12.2006 20:29:16
Hallöle allerseits,
Was macht Excel da eigentlich?
In Spalte A steht eine Reihe von Datumsangaben, in Spalte B Zahlen.
Nun möchte ich mit der Formel
{=SUMME(WENN(MONAT($A$1:$A$50)=2;$B$1:$B$50))}
nur die Zahlen in Spalte B addiert haben die in Spalte A den Monat „2“ also Februar enthalten. Funktioniert einwandfrei mit allen Monaten, bis auf den Januar.
Lösche ich ein Datum das den Januar enthält passiert in der Summe nichts obwohl diese sich demnach um die nebenstehende Zahl vermindern müsste, lösche ich ein Datum mit z.B. dem Monat „4“ so wird die entsprechende Summe folgerichtig vermindert und gleichzeitig wird die Summe die den „Januar“ enthalten soll um die entsprechende Zahl erhöht Kann mir jemand erklären was Excel da eigentlich treibt?
Übrigens bringen die Formeln
{=SUMMENPRODUKT(WENN(MONAT($A$1:$A$50)=2;$B$1:$B$50))} oder
{=SUMME(WENN(GANZZAHL(MONAT($A$1:$A$50))=2;$B$1:$B$50))}
auch keine anderen Ergebnisse.
Vielleicht hat ja einer eine Erklärung warum das so ist.
MfG
UlliDO
Bild

Betrifft: AW: Summe Datumabhängig
von: Ulf M
Geschrieben am: 12.12.2006 20:38:01
Hallo Ulli
Eine leere Zelle ist auch Monat Januar
versuch mal mit
=SUMMENPRODUKT((MONAT($A$1:$A$50)=1)*($A$1:$A$50<>"")*$B$1:$B$50)
mfg Ulf
 Bild