Herbers Excel-Forum - das Archiv

Datum

Bild

Betrifft: Datum
von: Robert

Geschrieben am: 13.12.2006 10:57:30
Hallo zusammen,
ich habe folgendes Problem:
Ich muss eine Altersberechnung machen zu einem bestimmten Stichtag. Leider macht Excel da immer einen Fehler, wobei das bestimmt an meiner Formel liegt.
Beispiel:
Stichtag: 01.07.2007
Geburtstag: 06.07.1945
Meine Formel =(Stichtag-Geburtstag)/365
Das Ergebnis verwende ich dann wieder in einem sverweis. Das funktioniert auch ohne Probleme. Aber es kommt ein falsches Ergebnis raus.
Wenn ich jetzt den Geburtstag auf 06.08.1945 verändere, dann stimmt wieder das Ergebnis. Da muß irgendwie was falsch laufen.
Wobei ich mit meiner Formel nicht zufrieden bin. Ich hoffe, ich konnte das Problem verständlich erläutern.
Vielen Dank für Eure Hilfe.
gruß
Robert
Bild

Betrifft: AW: Datum
von: yps
Geschrieben am: 13.12.2006 11:00:57
hi,
sieh dir das mal an:
http://www.excelformeln.de/formeln.html?welcher=141
cu Micha
Bild

Betrifft: AW: Datum
von: Reinhard

Geschrieben am: 13.12.2006 11:03:53
Hi Robert,
meisnt du sowas:
Tabelle:
[Mappe1]!Tabelle2
│      A     │      B     │  C │
──┼────────────┼────────────┼────┤
1 │ 01.07.2007 │ 06.07.1945 │ 61 │
──┴────────────┴────────────┴────┘
Benutzte Formeln:
C1:  =DATEDIF(B1;A1;"y")

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Datum
von: Robert
Geschrieben am: 13.12.2006 11:28:14
Hallo Reinhard,
danke für die Info. Hat mir geholfen. Aber wenn ich es jetzt in den Sverweis einbaue, dann funktioniert der sverweis nicht mehr. Aber egal, ich werde es mit einer extra spalte lösen.
gruß
Robert
Bild

Betrifft: AW: Datum
von: Reinhard
Geschrieben am: 13.12.2006 11:35:18
Hi Robert,
wie sieht der Sverweis aus?
Gruß
Reinhard
Bild

Betrifft: AW: Datum
von: Robert
Geschrieben am: 13.12.2006 11:42:57
Der Sverweis sieht so aus:
=SVERWEIS(Datedif(A2;A1;"y");$A$1:$B$41;2)
und er funktioniert leider nicht.
Gruß
Robert
Bild

Betrifft: AW: Datum
von: Reinhard

Geschrieben am: 13.12.2006 11:51:14
Hi Robert,
funktioniert doch problemlos,
Tabelle:
[Mappe2]!Tabelle1
│      A     │  B  │  C  │  D │  E  │
──┼────────────┼─────┼─────┼────┼─────┤
1 │ 01.07.2007 │     │   e │  1 │   a │
2 │ 08.07.1945 │     │     │  3 │   b │
3 │            │     │     │  6 │   c │
4 │            │     │     │  9 │   d │
5 │            │     │     │ 61 │   e │
6 │            │     │     │ 23 │   f │
──┴────────────┴─────┴─────┴────┴─────┘
Benutzte Formeln:
C1:  =SVERWEIS(DATEDIF(A2;A1;"y");$D$1:$E$41;2;0)
Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..

Bild

Betrifft: AW: Datum
von: Robert
Geschrieben am: 13.12.2006 12:00:59
Ok, Reinhard. Es funktioniert! Danke
 Bild