Herbers Excel-Forum - das Archiv

Jahreskalender

Bild

Betrifft: Jahreskalender
von: Axel

Geschrieben am: 13.12.2006 17:32:49
Hallo Excel-Experten,
ich habe einen Jahreskalender gebastelt der beruflich genutzt werden soll. Ich stecke doch jetzt etwas fest.
https://www.herber.de/bbs/user/38958.xls
Ich möchte z.B. das nur die Zellen sichtbar sind, die auch wirklich mit Tagen belegt sind. Also z.B.: Der 31.01.2007 ist Mittwoch der ist sichtbar. Es sollen aber nicht die Spalten Do.,Fr.,Sa.und So. sichtbar sein.
Wenn Ihr jetzt Februar drückt, sollen wiederum die ersten leeren Spalten verschwinden und auch wieder die letzten.
Versteht Ihr was ich meine?
Wer schön wenn Ihr mir helfen könntet.
Viele Grüße
Axel
Bild

Betrifft: AW: Jahreskalender
von: Reinhard

Geschrieben am: 13.12.2006 17:51:11
Hi Axel,
es wimmelt doch von Ecelkalendern im Internet, warum nicht da einen nehmen?
Tabelle:
C:\Download\[38958.xls]!Februar
│    B   │  C  │  D  │  E  │  F │  G │  H │  I │
───┼────────┼─────┼─────┼─────┼────┼────┼────┼────┤
12 │        │     │     │     │ Do │ Fr │ Sa │ So │
14 │        │     │     │     │  1 │  2 │  3 │  4 │
15 │   Früh │     │     │     │    │    │    │    │
16 │ Mittel │     │     │     │    │    │    │    │
17 │  Nacht │     │     │     │    │    │    │    │
18 │        │     │     │     │    │    │    │    │
19 │    Tag │     │     │     │    │    │    │    │
20 │        │     │     │     │    │    │    │    │
───┴────────┴─────┴─────┴─────┴────┴────┴────┴────┘
Benutzte Formeln:
C12:  =WENN(C14>0;"Mo";"")
C14:  =WENN(C13=C11;1;0)
D12:  =WENN(D14>0;"Di";"")
D14:  =WENN(C14<>0;C14+1;WENN(D13=$C11;1;0))
E12:  =WENN(E14>0;"Mi";"")
E14:  =WENN(D14<>0;D14+1;WENN(E13=$C11;1;0))
F12:  =WENN(F14>0;"Do";"")
F14:  =WENN(E14<>0;E14+1;WENN(F13=$C11;1;0))
G12:  =WENN(G14>0;"Fr";"")
G14:  =WENN(F14<>0;F14+1;WENN(G13=$C11;1;0))
H12:  =WENN(H14>0;"Sa";"")
H14:  =WENN(G14<>0;G14+1;WENN(H13=$C11;1;0))
I12:  =WENN(I14>0;"So";"")
I14:  =WENN(H14<>0;H14+1;WENN(I13=$C11;1;0))

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Jahreskalender
von: Axel

Geschrieben am: 13.12.2006 18:26:52
Hallo Reinhard,
danke für die schnelle Antwort.
Ich meinte jedoch was anderes.
Um beim Februar zu bleiben....
Es sollen alle Zellen ohne Datum
verschwinden. Also von C12 bis E20.
Inclusive Umrandung. Geht das nicht
mit der Formartierung?
Bild

Betrifft: AW: Jahreskalender
von: Reinhard
Geschrieben am: 13.12.2006 18:34:14
Hi Axel,
meinst du so oder wie?
Userbild
Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Jahreskalender
von: Axel
Geschrieben am: 13.12.2006 18:53:59
Genau Reinhard. :-)
Bild

Betrifft: AW: Jahreskalender
von: Reinhard
Geschrieben am: 13.12.2006 18:59:57
Hi Axel,
das geht doch relativ einfach mit bed. Formatierung.
Gruß
Reinhard
Bild

Betrifft: AW: Jahreskalender
von: Axel
Geschrieben am: 13.12.2006 19:09:22
Ja dachte ich mir.
Ich bekomme es sicher hin.
Hab aber noch mehr Fragen.
Kommen aber später.
Gruß
Axel
Bild

Betrifft: Prima ... und zu ...
von: zu
Geschrieben am: 13.12.2006 22:11:10
.
 Bild
Excel-Beispiele zum Thema "Jahreskalender"
Jahreskalender mit Monatsblättern anlegen Jahreskalender und bedingte Formatierung
Zellkontextmenü durch Jahreskalender ersetzen Jahreskalender mit KW nach DIN1355 anlegen
Jahreskalender mit Mitarbeiterliste und Feiertagen anlegen Jahreskalender als Menü anlegen