Herbers Excel-Forum - das Archiv

Alter ausrechnen und noch zwei weitere Frage

Bild

Betrifft: Alter ausrechnen und noch zwei weitere Frage
von: Eisbaer

Geschrieben am: 19.12.2006 02:49:48
Liebe Leute,
1. Frage:
Wenn ich in Zelle N5 ein Geburtsdatum eigebe, bekomme ich mit der Formel =DATEDIF(A1;HEUTE();"y") in der Zelle Q5 das aktuelle Lebensalter berechnet. Leider taucht ein Problem auf: Steht in N5 noch kein Datum, berechnet Excel mir automatisch in der Zelle Q5 bereits einen Wert von "106".
Wie kann ich das verhindern?
2. Frage:
Wenn ich in Zelle B5 einen Datumseintrag vornehme, soll in Zelle H5 eine "1" erscheinen. Wie kann ich das erreichen?
3. Frage:
Ich möchte die Zeitspanne zwischen 2 Daten in angefangenen Wochen (ohne Nachkommastelle) in 7 Kategorien darstellen.
Datum 1 steht in Zelle B5
Datum 2 steht in Zelle W5
Die Zeitspanne "bis 12 Wochen" steht in X5
Die Zeitspanne "bis 24 Wochen" in Y5
Die Zeitspanne "bis 36 Wochen" in Z5
Die Zeitspanne "bis 48 Wochen" in AA5
Die Zeitspanne "bis 60 Wochen" in AB5
Die Zeitspanne "bis 78 Wochen" in AC5
Die Zeitspanne "über 78 Wochen" in AD5
Wie funktioniert das?
Viele Grüße vom Eisbaer.
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: Georg
Geschrieben am: 19.12.2006 03:02:20
zu 1.:
in q5 muss stehen: =Wenn(ISTLEER(N5)=Wahr;"";DATEDIF(A1;HEUTE();"y"))
zu 2.:
in h5 muss stehen: =Wenn(ISTLEER(N5)=Wahr;"";"1")
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: Eisbaer

Geschrieben am: 19.12.2006 03:31:43
Guten Morgen Georg,
Dein Vorschlag zu "2." funktioniert gut, beim Vorschlag zu "1." habe ich das gleiche Problem wie vorher: Excel errechnet "106". Woran liegt das bloß?
Hast Du zu "3." auch noch einen Vorschlag?
Dank vom Eisbaer.
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: Walter

Geschrieben am: 19.12.2006 04:25:44
Hallo Eisbaer,
Gebe diese Formel ein und das Geburtsdatum in A1, nicht in N5.
=WENN(A1="";"";DATEDIF(A1;HEUTE();"y"))
Deine dritte Frage ist mir etwas unklar.
Gruß
Rentner Walter
aus dem nördlichen Nordhessen
Eine Antwort wäre nett!
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: Erich G.

Geschrieben am: 19.12.2006 09:11:22
Hallo Einsbaer(?),
bei Frage 3 ist mir nicht klar, was wo als Ergebnis stehen sollte.
Mit 72 statt 78 ginges es z. B. so:
(Spalte Y ist nur zur Info, wird nicht gebraucht)
 BHNQWXY
4vonDatumbis1Alterbis212er-WochenWochen dez.
501.01.2007119.12.2003325.03.2007bis 12 Wochen11,857143
601.01.2007131.12.2003226.03.2007bis 12 Wochen12,000000
701.01.2007101.01.2004217.06.2007bis 24 Wochen23,857143
801.01.2007118.12.2005118.06.2007bis 24 Wochen24,000000
901.01.2007119.12.2005119.06.2007bis 36 Wochen24,142857
1001.01.2007120.12.2005020.06.2007bis 36 Wochen24,285714
1101.01.20071  19.05.2008bis 72 Wochen72,000000
1201.01.20071  20.05.2008über 72 Wochen72,142857
1301.01.20071  11.08.2008über 72 Wochen84,000000
1401.01.20071  11.03.2009über 72 Wochen114,285714

Formeln der Tabelle
ZelleFormel
H5=WENN(ISTZAHL(B5);WENN(UND(DATWERT("1.1.1975")<=B5;DATWERT("1.1.2025")>B5);1;"");"")
Q5=DATEDIF(N5;HEUTE();"y")
X5=WENN(W5>B5+72*7;"über 72 Wochen";"bis "&12*MAX(1;AUFRUNDEN((W5-B5)/84;0))&" Wochen")
Y5=(W5-B5)/7

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: Eisbaer

Geschrieben am: 19.12.2006 19:31:10
Hallo Erich,
es geht mir um folgendes:
Ein Auto wird am 01.01.2007 zugelassen. Dies Datum steht in B5.
Das Auto wird am 30.06.2007 abgemeldet. Dies Datum steht in W5.
Da dies gerundet 26 Wochen sind, fällt die Dauer in die Kategorie "bis 36 Wochen" und es soll eine "1" erscheinen in der Zelle Z5.
Würden sich für einen anderen Zulassungszeitraum z.B. 61 Wochen ergeben, soll die "1" in Zelle AC5 erscheinen.
Bekommst Du das hin?
Viele Grüße aus der Nähe von Hamburg vom Eisbaer.
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: HermannZ

Geschrieben am: 19.12.2006 20:14:30
Hallo Eisbaer;
meinst du das so???
Beispiel;
Die Formel kann nach rechts und nach unten kopiert werden.
Leer
 BWXYZAAABACAD
3         
4  bis 12 Wochenbis 24 Wochenbis 36 Wochenbis 48 Wochenbis 60 Wochenbis 78 Wochenüber 78 Wochen
501.01.200730.06.2007  1    
6         
Formeln der Tabelle
X5 : =WENN(VERGLEICH(RUNDEN(DATEDIF($B$5;$W$5;"D")/7;0);{0.12.24.36.48.60.78})=SPALTE(A1);1;"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß HermannZ
Bild

Betrifft: AW: Alter ausrechnen und noch zwei weitere Frage
von: Eisbaer
Geschrieben am: 19.12.2006 21:35:25
Hallo HermannZ,
danke, genauso meinte ich's!
Gruß vom Eisbaer.
 Bild
Excel-Beispiele zum Thema "Alter ausrechnen und noch zwei weitere Frage"
Mit der aktiven Zelle jeweil 9 weitere in der Zeile markieren Nach Eingabe eines S keine weiteren Eingaben möglich
Weiteren Verlauf prognostizieren