Herbers Excel-Forum - das Archiv

Zählewenn

Bild

Betrifft: Zählewenn
von: Adem

Geschrieben am: 19.12.2006 10:40:42
Hallo Allerseits!
Wenn man in einer Tabelle feststellen möchte, wie oft ein Wert (Zahl oder Text) vorhanden ist, kann man dies mit der Funktion ZÄHLENWENN (Bereich;Kriterien) tun.
Mein Problem ist, dass ich Zahlen von 0-9999 habe und einige von diesen doppelt oder öfters vorkommen! Ideal wäre eine Formel, die überprüft, ob eine Zahl mehr als nur einmal vorkommt. Wenn ja, dann soll die mehrfach vorkommende Zahl in die erste Spalte un die Anzahl dieser mehrfach vorkommenden Zahl in die 2 Spalte geschrieben. Falls nur ein Makro weiterhelfen sollte dann weiss ich wo meine Grenzen sind! :-)
Grüße aus Darmstadt
Adem
Bild

Betrifft: AW: Zählewenn
von: HermannZ

Geschrieben am: 19.12.2006 12:02:15
Hallo Adem;
so ganz blicke ich durch deine Beschreibung nicht durch.Meinst du das so???
Beispiel;
Doppelt
 ABCD
531Wie oft kommt ein Doppelter-Eintrag vor?   
532    
533Name nur DoppelteAnzahl
534123456 1234563
535234567 2345672
536345678   
537123456   
538678901   
539567890   
540234567   
541123456  
542  Formeln nach 
543  unten kopieren 
Formeln der Tabelle
C534 : {=WENN(SUMME((WENN(A$534:A$541="";0;1/ZÄHLENWENN(A$534:A$541;A$534:A$541))<1)*(1/ZÄHLENWENN(A$534:A$541;A$534:A$541)))<ZEILE(A1);"";INDIREKT("A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$534;;;ZEILE($1:$8));A$534:A$541)>1;ZEILE($534:$541));ZEILE(A1))))}
D534 : =ZÄHLENWENN($A$534:$A$541;C534)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß HermannZ
Bild

Betrifft: AW: Zählewenn
von: adem
Geschrieben am: 19.12.2006 12:19:48
Genau so meine ich das.......und das hast du trotz meiner undurchschaubaren Erklärung geschafft :-)
Mal sehen wie lange ich brauche um da durchzublicken.
Vielen vielen Dank!
Wünsche einen schönen Tag
Adem
Bild

Betrifft: AW: Danke für die Rückantwort.........oT.
von: HermannZ
Geschrieben am: 19.12.2006 14:10:11
Gruß HermannZ
 Bild