Herbers Excel-Forum - das Archiv

Summe mit Zellfehlern

Bild

Betrifft: Summe mit Zellfehlern
von: Alexander

Geschrieben am: 22.12.2006 13:27:32
Hi,
Ich moechte in einer Zelle die Summe aus verschiedenen anderen Zellen abbilden, die jeweils ueber Formeln eine Zahl anzeigen. Da manche dieser Zellen jedoch einen Fehler anzeigen koennen (z.B. weil sie durch 0 dividieren etc.) kann die Summe nicht gebildet werden sondern es wird ebenfalls ein Fehler angezigt (z.B. REF oder DIV/0 etc.)
Wie kann ich Fehlerwerte in diesem Fall als Wert=0 definieren und damit in der Summenzelle doch das Ergebniss anzeigen? oder anders: Wie kann ich Fehlerwerte aus Zellen die in eine Summenrange gehoeren mit dem Wert 0 in die Summenrechnung einbeziehen?
Vielen Dank und Frohe Weihnachten.
Alexander
Bild

Betrifft: AW: Summe mit Zellfehlern
von: Daniel Eisert

Geschrieben am: 22.12.2006 13:38:59
Hallo
meines Wissens nach musst du die Fehler schon in den Einzelformeln vermeiden, dh. wenn die Möglichkeit einer Division durch 0 besteht, muß diese per Formel ausgeschlossen werden.
Also in etwa so:
=wenn(oder(B1=0;B1="");"Dein Fehlertext";A1/B1)
Wenn du mit Sverweis oder Vergeleich arbeitest, musst du mit ISTFEHLER(SVerweis...) oder ZählenWenn vorher abprüfen, ob der Wert vorhanden ist. Also in etwa so:
=wenn(zählenwenn(C1:C10);A1)=0;"Fehlertext";sverweis(A1;C1:D10;2;0))
oder halt in VBA eine modifizierte Summenformel schreiben, die Fehlerwerte ignoriert.
Aber davon würde ich, solange es sich mit normalen Formeln realisiern lässt, abraten.
Gruß, Daniel
Bild

Betrifft: AW: Summe mit Zellfehlern
von: Daniel Eisert

Geschrieben am: 22.12.2006 13:51:01
Hallo
falls du es doch mit ner UDF versuchen willst, wäre das ne einfache Möglichkeit, die Summe für einen Zellbereich ohne Fehler zu bilden:
Function SummeNeu(Bereich)
Dim arr
Dim a
arr = Bereich.Value
For Each a In arr
If IsNumeric(a) Then SummeNeu = SummeNeu + a
Next
End Function

Gruß, Daniel
Bild

Betrifft: AW: Summe mit Zellfehlern
von: Klaus M.vdT.

Geschrieben am: 22.12.2006 14:51:47
Hallo,
Oder du realisierst das mit einer Matrixformel:
{=SUMME(WENN(ISTFEHLER(A1:A10);0;A1:A10))}
Für Werte ausser Fehlerwerten in A1:A10.
geschweifte Klammern nicht mit eingeben, sondern mit STRG+SHIFT+ENTER abschließen.
Gruß,
Klaus M.vdT.
Bild

Betrifft: AW: Summe mit Zellfehlern
von: Alexander
Geschrieben am: 22.12.2006 16:30:05
Super, das klappt. Dankeschoen.
Bild

Betrifft: Fehlerwerte behandeln
von: Beate Schmitz

Geschrieben am: 22.12.2006 16:00:29
Hallo Alexander,
ich würde dir auch empfehlen, die Fehlerausgabe in den Vorgängerzellen auszuschalten.
Guckst Du: Fehlerwerte behandeln - nutzen
Gruß,
Beate
 Bild