Herbers Excel-Forum - das Archiv

Frage Umformiliert - Index über mehrere Sheets

Bild

Betrifft: Frage Umformiliert - Index über mehrere Sheets
von: Alex

Geschrieben am: 26.12.2006 15:06:17
Hallo Excelprofis,
sorry, doch meine erste Anfrage war wohl nicht ganz vollständig.
Kann ich die folgende Formel entsprechend Umstellen??????????
Beispiel bisherige Formel:
WENN(ISTNV
(INDEX('C:\[A.xls]Seite10'!$A$8:$BN$1100
VERGLEICH(P39;'C:\[A.xls]Seite10'!$A$8:$A$1100;0);
VERGLEICH(T39;'C:\[A.xls]Seite10'!$A$8:$BN$8;0)));
"F";
(INDEX('C:\[A.xls]Seite10'!$A$8:$BN$1100
;VERGLEICH(P39;'C:\[A.xls]Seite10'!$A$8:$A$1100;0);
VERGLEICH(T39;'C:\[A.xls]Seite10'!$A$8:$BN$8;0))))
Beispiel neue Formel:
(INDEX('Workbookpfad = AA39 + Worksheetname = AB39'!$A$8:$BN$1100;
VERGLEICH(P39;'Workbook = AA39 + Worksheetname = AB39'!$A$8:$A$1100;0);
VERGLEICH(T39;'Workbook = AA39 + Worksheetname = AB39'!$A$8:$BN$8;0)));
"F";
(INDEX('Workbook = AA39 + Worksheetname = AB39'!$A$8:$BN$1100
;VERGLEICH(P39;'Workbook = AA39 + Worksheetname = AB39'!$A$8:$A$1100;0);
VERGLEICH(T39;'Workbook = AA39 + Worksheetname = AB39'!$A$8:$BN$8;0))))
In Zelle AA39 Wäre der Pfad zum Workbook Beispiel: c:\Mappe1.cls
In Zelle AB39 wäre der Pfad zum Worksheet Beispiel: Seite10
Ist das so überhaupt möglich, oder muss ich hier zu einer VBA-Lösung greifen????
Für Hilfe wäre ich unendlich Dankbar
Gruß Alex
Bild

Betrifft: AW: Frage Umformiliert - Index über mehrere Sheets
von: Erich G.

Geschrieben am: 27.12.2006 20:18:20
Hallo Alex,
Verzeichnis und Mappe sollten in getrennten Zellen getrennt stehen, oder zusammen in einer Zelle,
wobei aber der Mappenname in eckige Klammern eingeschlossen ist.
Hier hast du drei Möglichkeiten - je nachdem, wie Verzeichnis, Mappe und Blatt in deiner Tabelle stehen sollen:
 VWXZAAABACAD
39FFFf:\exc\w-w-w\tmp\alex.xlsSeite10f:\exc\w-w-w\tmp\[alex.xls]Seite10'f:\exc\w-w-w\tmp\[alex.xls]Seite10'

Formeln der Tabelle
ZelleFormel
V39=WENN(ISTNV(INDEX(INDIREKT("'"&Z39&"["&AA39&"]"&AB39&"'!$A$8:$BN$1100"); VERGLEICH(P39;INDIREKT("'"&Z39&"["&AA39&"]"&AB39&"'!$A$8:$A$1100");0); VERGLEICH(T39;INDIREKT("'"&Z39&"["&AA39&"]"&AB39&"'!$A$8:$BN$8");0)));"F"; INDEX(INDIREKT("'"&Z39&"["&AA39&"]"&AB39&"'!$A$8:$BN$1100"); VERGLEICH(P39;INDIREKT("'"&Z39&"["&AA39&"]"&AB39&"'!$A$8:$A$1100");0); VERGLEICH(T39;INDIREKT("'"&Z39&"["&AA39&"]"&AB39&"'!$A$8:$BN$8");0)))
W39=WENN(ISTNV(INDEX(INDIREKT("'"&AC39&"'!$A$8:$BN$1100"); VERGLEICH(P39;INDIREKT("'"&AC39&"'!$A$8:$A$1100");0); VERGLEICH(T39;INDIREKT("'"&AC39&"'!$A$8:$BN$8");0)));"F"; INDEX(INDIREKT("'"&AC39&"'!$A$8:$BN$1100"); VERGLEICH(P39;INDIREKT("'"&AC39&"'!$A$8:$A$1100");0); VERGLEICH(T39;INDIREKT("'"&AC39&"'!$A$8:$BN$8");0)))
X39=WENN(ISTNV(INDEX(INDIREKT(AD39&"!$A$8:$BN$1100"); VERGLEICH(P39;INDIREKT(AD39&"!$A$8:$A$1100");0); VERGLEICH(T39;INDIREKT(AD39&"!$A$8:$BN$8");0)));"F"; INDEX(INDIREKT(AD39&"!$A$8:$BN$1100"); VERGLEICH(P39;INDIREKT(AD39&"!$A$8:$A$1100");0); VERGLEICH(T39;INDIREKT(AD39&"!$A$8:$BN$8");0)))
AC39=Z39&"["&AA39&"]"&AB39
AD39="'"&Z39&"["&AA39&"]"&AB39&"'"

Rückmeldung wäre nett! - Erich aus Kamp-Lintfort wünscht allen einen guten Rutsch!
 Bild
Excel-Beispiele zum Thema "Frage Umformiliert - Index über mehrere Sheets"
Suche über mehrere Tabellen Mehrere Schaltflächen für ein Makro
Suchbegriff über mehrere Tabellenblätter suchen. Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Druck aus mehreren Tabellenblättern auf eine Druckseite AutoFilter über mehrere Arbeitsblätter setzen
Daten von mehreren Blättern auf ein Druckblatt Prozentuale Erhöhung über mehrere Arbeitsblätter hinweg
Werte in mehreren Spalten sortieren Textreihe auf mehrere Spalten mit fester Seitenlänge verteilen