Herbers Excel-Forum - das Archiv

#NV verhindern

Bild

Betrifft: #NV verhindern
von: Günter

Geschrieben am: 26.12.2006 15:20:10
Frohes Fest zusammen,
ich weiß es ist ein Feiertag, aber es lässt mich nicht los.
Mit einer Indexformel lese ich ein Blatt aus.~ =(INDEX('[Liste AGH Eingaenge.xls]Kunden'!$C$2:$C$1000&" "&'[Liste AGH Eingaenge.xls]Kunden'!$D$2:$D$1000;VERGLEICH(C6;'[Liste AGH Eingaenge.xls]Kunden'!$AD$2:$AD$1000;0)))~
Wenn die Formel keinen Wert in einer Zelle findet wird #NV wiedergegeben. Das möchte ich vermeiden, weiß aber nicht genau wie.
Mit bedingter Formatierung hat es nicht geklappt.
Gibt es einen Tipp?
Günter
Bild

Betrifft: AW: #NV verhindern
von: HermannZ

Geschrieben am: 26.12.2006 15:54:44
Hallo Günter;
=WENN(ISTFEHLER(VERGLEICH(C6;'[Liste AGH Eingaenge.xls]Kunden'!$AD$2:$AD$1000;0));"";INDEX('[Liste AGH Eingaenge.xls]Kunden'!$C$2:$C$1000&" "&'[Liste AGH Eingaenge.xls]Kunden'!$D$2:$D$1000;VERGLEICH(C6;'[Liste AGH Eingaenge.xls]Kunden'!$AD$2:$AD$1000;0)))
Gruß HermannZ
Bild

Betrifft: AW: #NV verhindern
von: Günter
Geschrieben am: 26.12.2006 16:17:59
vielen Dank,
und ein frohes Fest für den Rest.
Günter
Bild

Betrifft: AW: Danke und auch dir noch Frohes Fest...oT
von: HermannZ
Geschrieben am: 26.12.2006 16:22:48
Gruß HermannZ
 Bild
Excel-Beispiele zum Thema "#NV verhindern"
Nichtnumerische Eingaben verhindern Fehlermeldung #DIV/0! verhindern
Wechselweise den Eintrag einer 1 verhindern Programmabbruch bei Überspeichernabfrage verhindern
Nichtnumerische Eingaben in TextBox verhindern Auswahl eines Zellbereiches verhindern
Vertikalen Seitenumbruch verhindern Verhindern des Schließens einer UserForm mittels Schließkreuz
Aufhebung der Workbook_Open-Befehle verhindern Editieren von Zellen durch DoppelKlick verhindern