Herbers Excel-Forum - das Archiv

vergleichsfunktion

Bild

Betrifft: vergleichsfunktion
von: Jon

Geschrieben am: 27.12.2006 15:30:35
hallo erstmal,
ich möchte eine Zahl mit einer feste Zahlentabelle vergleichen und dann eine Punktergebniss vergeben. Bei keine Übereinstimmung sollte immer der nächst niedrige Zahl genommen werden zB.:
Zahltabelle Punkte
500 ---------- 2
750----------- 3
1000---------- 4
usw......
wenn 699 der eingegebe Zahl ist dann mussen entsprechend 2 Punkte als ergebniss angezeigt werden.
Ich hoffe das ich es verständlich dagestellt habe.
Vielen Dank und guten Rutsch
Jon
Bild

Betrifft: Sverweis
von: Mac4
Geschrieben am: 27.12.2006 15:35:51
Hi,
=SVERWEIS(A1;B:C;2)
In A1 steht das Suchkriterium (hier 699) gesucht wird in Spalte B - der Wert aus C wird zurückgegeben!
Marc
Bild

Betrifft: AW: vergleichsfunktion
von: Bertram
Geschrieben am: 27.12.2006 15:37:04
Hi Jon,
so? https://www.herber.de/bbs/user/39203.xls
Gruß
Bertram
Bild

Betrifft: AW: vergleichsfunktion
von: jockel

Geschrieben am: 27.12.2006 16:46:09
hi Bertram, ich weiß nicht, ob du absichtlich den bereichs_verweis weggelassen hast, aber wer den SVERWEIS() nicht kennt, dem sei gesagt, dass dieser nicht unwichtig ist.
deine formel =SVERWEIS(D1;A1:B3;2) lautet in wirklichkeit: =SVERWEIS(D1;A1:B3;2;1) bzw. =SVERWEIS(D1;A1:B3;2;WAHR)
einen interessanten exkurs in sachen SVERWEIS() erhält man hier: http://www.online-excel.de/excel/singsel.php?f=9
cu jörg
 Bild