Herbers Excel-Forum - das Archiv

Funktionserweiterungen

Bild

Betrifft: Funktionserweiterungen
von: KarlD

Geschrieben am: 05.01.2007 09:30:41

Die Datei https://www.herber.de/bbs/user/39398.xls wurde aus Datenschutzgründen gelöscht

Hallo, Forum,
mein Problem habe ich in der angefügten Datei dargelegt. Gibt es dafür eine Lösung?
Gruß
Karl
Bild

Betrifft: AW: Funktionserweiterungen
von: Ramses

Geschrieben am: 05.01.2007 09:51:17
Hallo
Deine Formel zur Berechnung des Alters ist falsch
Dateneingabe

 ABCDEFGHI
1SGB II1    ja  
2Geburtsdatum10.1.1956Ü50  
3SV-Jahressatz20.00%   
4Leistungshöhe30.00%   
5mtl. Gehalt3'000.00  0
6Ergebnis1'080.00      
7         

Formeln der Tabelle
ZelleFormel
A1=WENN(B1=1;"SGB II";"SGB III")
G1=WENN(B1=1;"ja";"")
G2=WENN(TAGE360(B2;HEUTE())/360 >50;"Ü50";"")
B6=WENN(I5>0;RUNDEN(I5*B4;2)+RUNDEN((I5*B4)*B3;2);WENN(UND(RUNDEN(B5*B4;2)+RUNDEN((B5*B4)*B3;2)>=950;G2="Ü50");RUNDEN(B5*B4;2)+RUNDEN((B5*B4)*B3;2);950))

Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML    Download  
Gruss Rainer
Bild

Betrifft: AW: Funktionserweiterungen
von: KarlD
Geschrieben am: 05.01.2007 09:58:49
Ich nehme an, die korrekte Formel finde ich im angehängten Downlaod. Kann von hier aus keinen download machen, deshalb werde ich mir die Formel später ansehen.
Gr.
KarlD
Bild

Betrifft: AW: Funktionserweiterungen
von: Ramses

Geschrieben am: 05.01.2007 10:06:06
Hallo
Es gibt grundsätzlich keinen angehängten Download von mir :-)
Die benötigten Formeln sind in meinem Beitrag, die Alterberechnung musst du selbst korrigieren, da ich nicht weiss welche Kriterien zugrunde liegen.
Aber in meinem Beispiel dürfte der Eintrag "Ü50" erst nächste Woche kommen :-)
Gruss Rainer
Bild

Betrifft: AW: Funktionserweiterungen
von: Ludicla
Geschrieben am: 05.01.2007 10:23:12
Hey KarlD
vielleicht hilfts.
https://www.herber.de/bbs/user/39403.xls
Gruss Ludicla
Bild

Betrifft: AW: Funktionserweiterungen
von: KarlD

Geschrieben am: 05.01.2007 11:10:27
Hallo, Ludicla,Rainer
jeder von Euch hat mir eine Bedingung in die Zelle geschrieben, aber ich bräuchte die Bedingung so, dass entweder und/oder G1 / G2 berücksicht werden müssen. D.h. wenn ein Eintrag entweder in G1 oder G2, oder sowohl in G1 als auch in G2 vorliegt, dann muss die Zelle normal rechnen und den Betrag nicht auf 950 begrenzen.
Bild

Betrifft: AW: Funktionserweiterungen
von: Ramses
Geschrieben am: 05.01.2007 11:55:39
Hallo
Das war nicht deine Frage.
Diese Bedingung ist anders, da aber nun zwei Varianten vorhanden sind, solltest du diese mit ein wenig Nachdenken :-) kombinieren können.
Gruss Rainer
Bild

Betrifft: AW: Funktionserweiterungen
von: KarlD
Geschrieben am: 05.01.2007 11:26:57
Hallo, Ludicla,
mit dieser Formel hat es geklappt. Das Problem ist gelöst.
Vielen Dank und ein schönes Wochenende
Gr.
Karl
 Bild